
Thermo-Calc Installation Guides
Thermo-Calc Version 2023a
Including the TC-Python and TC-Toolbox for MATLAB® Installation Guides



Copyright 2023 Thermo-Calc Software AB. All rights reserved.

Information in this document is subject to change without notice. The software or database 
described in this document is furnished under a license agreement or nondisclosure 
agreement. The software or database may be used or copied only in accordance with the terms 
of those agreements. You can read more on our website.

Thermo-Calc Software AB

Råsundavägen 18, SE-169 67 Solna, Sweden

+46 8 545 959 30

www.thermocalc.com

https://thermocalc.com/terms-and-conditions-for-the-purchase/


Installing Thermo-Calc

Installing Thermo-Calc ǀ 3 of 150

Installing Thermo-Calc
In this section:

Key to Using this Guide 4

Installation Terminology 6

About the Thermo-Calc Components Being Installed 8

System Requirements 10

Platforms Tested and SDK Availability 11



Installing Thermo-Calc

Key to Using this Guide ǀ 4 of 150

Key to Using this Guide

This guide is available in PDF format: (1) On the website or (2) when in 
Thermo-Calc go to Help → Manuals Folder → Installation.

This installation guide is for all Thermo-Calc installations running on Windows, macOS, or Linux 
operating systems. It is also applicable to  previously installed versions of Thermo-Calc (the new 
version is installed next to the old version). 

This guide includes information about:

 l The types of licenses and installations available.

 l Installing the Thermo-Calc software and its components on standalone computers, 
servers, and client computers.

 l Installing the license management software for network installations. 

 l Retrieving and installing license files.

 l Details about the specific instructions needed to install two of the SDKs, TC-Python and 
TC-Toolbox for MATLAB®. 

 l Troubleshooting to solve common installation problems.

 l Updating and uninstalling the software.

Icons in this Guide

Name Description

Information
Provides important information and indicates that more detail is located in 
the linked or named topic.

Note
The information can be of use to you. It is recommended that you read the 
text or follow the link.

Operating system The operating system is indicated when the information is specific to a Windows, macOS, or 

https://thermocalc.com/content/uploads/Documentation/Current_Static/thermo-calc-installation-guides.pdf
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Name Description

Linux operating system.  

 License file 
The Thermo-Calc license file, which contains the license keys and is installed on either a 
standalone computer or a network server.

 Thermo-Calc The Thermo-Calc software and its components (including databases and SDKs) to be installed.

Typographical Conventions

Convention Definition

Forward arrow →
The forward arrow symbol → instructs you to select a series of menu items in a specific 
order. For example, Tools → Options is equivalent to: From the Tools menu, select 
Options.

Boldface font
A boldface font indicates that the given word(s) are shown that way in on a toolbar 
button or as a menu selection. For example, if you are told to select a menu item in a 
particular order, such as Tools → Options, or to click Save.

Italic font
An italic font indicates the introduction of important terminology. Expect to find an 
explanation in the same paragraph or elsewhere in the guide.

code and code bold
A code font indicates you are to make a keyboard entry. It also shows a programming 
code or code examples. The code bold font highlights the entry.
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Installation Terminology

Term Definition

client 
A computer without a license file of its own but connected through the network to a 
computer with the license information. The client receives a license token from the 
computer where the license management software is installed.

consolidated network

A type of network installation where the Thermo-Calc software and a Thermo-Calc 
licensing software are installed on a single server computer. This allows all computers 
in the network to access both the software and a license on the server via a client 
installation.

distributed network

A type of network installation where the Thermo-Calc software is installed on one 
server computer in a network and the Thermo-Calc licensing software is installed on a 
different computer. After a thin client installation, all computers in the network can 
access both the software and the network license key via the server.

host ID The MAC address on the computer that a license is locked to. 

license file
The file (called lservrc) that contains all the purchased license keys. It is issued by 
Thermo-Calc Software, usually by email.

license key
The information contained in the license file that represents the products purchased 
and which is then authorised for installation.

license management software 
(see Sentinel RMS License 
Software)

The Thermo-Calc license management software. When working in Windows it is called 
License Manager (full name is Sentinel RMS License Manager by SafeNet) and on Linux 
it is called License Server (full name is Sentinel License Sever by Safenet).

license server

The use of the term license server (lower case letters) is reserved for use for scripts 
and option files (for example, in an "Unattended Network Client Installations" on 
page 63). For the purposes of the step-by-step instructions it is not used to refer to the 
type of network installation that runs the license management program. See Sentinel 
RMS Software below. 

Network License (NWL)

The license type used with the licensing software. The NWL can only be used on one 
specific computer that hosts the licensing software. This restricts license usage to a 
certain subnet or subnets.

The software may be used on the number of sites you have paid for and by the 
number of persons you have paid for on any number of network connected computers

Sentinel RMS License Software 

The Thermo-Calc license management software that supplies the client computers in 
your network with license tokens when it runs the Thermo-Calc software. This is 
available for both Windows (called the License Manager) and Linux (called the License 
Server, but not to be confused with license server in lower case letters reserved for 
scripts).
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Term Definition

Single-User-Node Locked-
License (SUNLL)

A unique license file for one designated computer at one designated site. It cannot be 
copied or moved outside the site. If the software is installed on a portable computer, it 
can be temporarily used off-site. The license can be used without network access (to 
the License Server).

standalone computer A computer which uses a SUNLL license type.

TC-Toolbox The short name for the  TC-Toolbox for MATLAB® SDK. 

thin client
An installation where the software is installed on a file server but is run from a client 
computer. The licensing software may be installed on the file server (consolidated 
network installation) or on a different computer (distributed network installation).

XQuartz An open-source X Windows System, which is required to run Thermo-Calc on a Mac.
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About the Thermo-Calc Components Being Installed
What is Installed with a Full Standalone or Full Network Client 
Option?

At the start of the installation process, the following components are installed when you 
choose either the Full Standalone or Full Network Client options. If you want to exclude a 
component (perhaps one of the SDKs), then you would use the Custom option.

A full installation means that all listed feature components are installed but the availability of 
the individual components is based on the license you have.    This is also applicable to the 
databases and software development kits (SDKs).  

Thermo-Calc

The Thermo-Calc software includes several add-on features and capabilities that are packaged 
with the software and included with a full standalone or network client installation. For 
example, there are the specialized add-on products Diffusion Module (DICTRA), Precipitation 
Module (TC-PRISMA), and Process Metallurgy Module as well as the Steel Model Library. For 
most of these specialized features, demonstration (demo) versions and/or examples are 
available for all users but advanced features are only available with a license. 

Databases

All the latest databases are installed. As with the software features, availability of a specific 
database in the software itself is based on license. However, several demonstration 
(demo) databases are included and available to all users. 
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Software Development Kits (SDKs) 

When the Full Standalone or Full Network Client option is chosen, it also installs the software 
development kits (SDKs) (e.g. TC-Python, TQ-Interface, TC-Toolbox for MATLAB®, etc.).

TC-Python

The TC-Python program is installed when the Full Standalone or Full Network Client option is 
chosen, but there are additional steps required to complete the installation as described in the 
TC-Python Installation Guide.

TC-Toolbox for MATLAB®

If a MATLAB® installation on your computer is found during this installation process,  the 
TC-Toolbox for MATLAB® (available only for Windows) is automatically installed, otherwise you 
may need to do a manual installation. For details, see the TC-Toolbox for MATLAB Installation 
Guide®.

What Does the Custom Option Allow Me to Do During an 
Installation?

During the installation process, there is some flexibility to choose what to include or exclude 
with the installation by choosing the Custom option. This is primarily to the level of being able 
to choose the SDKs or to exclude all databases or Thermo-Calc itself. That is, you cannot choose 
specific Thermo-Calc features or databases as these are controlled by the license and not the 
installation procedure. 
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System Requirements
"About the Thermo-Calc Components Being Installed" on page 8

General

A full list of system requirements and program availability is found on the Thermo-Calc website. 
You can also see the roadmap for platform support to use for planning purposes. 

Network Client Installations: Sentinel RMS License Software

Network client installations using the Sentinel RMS license management software 
require the use of the most recent version, 9.7.

For details of the system requirements to install Sentinel RMS, see "Windows: About Installing 
the License Manager" on page 46 and "Linux: About Installing the License Server" on page 51.

For macOS, the Sentinel RMS License software is installed on a Windows  or Linux  
computer server where the Thermo-Calc license file must also be located. 

https://thermocalc.com/system-requirements/
https://thermocalc.com/roadmap-for-platform-support/
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Platforms Tested and SDK Availability
A full list of system requirements and program availability is found on the Thermo-Calc website. 
You can also see the roadmap for platform support to use for planning purposes. 

Platforms Tested

Thermo-Calc and its components are tested on these platforms for Thermo-Calc 2023a:

Windows macOS Linux1, 2

 l Windows 10 64-bit

 l Windows 11

 l Ventura 13.0.1

 l Monterey 12.6.1

 l Ubuntu 20.04 (Focal Fossa)

 l CentOS 7.9

 l OpenSUSE 15.4

1 Thermo-Calc Software cannot guarantee full functionality if the software is installed on other Linux distributions.

2 If you are installing on CentOS 7, it is recommended you install gtk2 before you run the installation script. 

SDK Availability by Platform

The software development kits (SDKs) are available as follows for the indicated platforms:

SDK Windows macOS Linux

TC-Python x x x

TQ-Interface x not available x

TC-Toolbox for MATLAB® x not available not available

TC-API x not available x

https://thermocalc.com/system-requirements/
https://thermocalc.com/roadmap-for-platform-support/
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License and Installation Types
Installation procedures are based on the license type, the installation type, and the operating 
system. 

Visit our website for more information about Licensing Options.

For macOS, the Sentinel RMS License software is installed on a Windows  or Linux  
computer server where the Thermo-Calc license file must also be located. 

License type Installation Type Windows macOS Linux 

SUNLL Standalone Yes Yes Yes

NWL

Consolidated network Yes No Yes

Distributed network Yes No Yes

License installations on a server network Yes Yes Yes

Sentinel RMS License Management Software: Use Current Version

The most recent version (9.7) of the Sentinel RMS License Manager (Windows) and License 
Server (Linux) is included with the network license Thermo-Calc software download. 

However, due to security issues reported by the vendor, it is important that previous network 
license installations of the Sentinel RMS are upgraded to this version number. 

For more information for your operating system, see "Windows: About Installing the License 
Manager" on page 46 and "Linux: About Installing the License Server" on page 51

https://thermocalc.com/licensing-options/
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About License Keys and Files
To run Thermo-Calc and its components you need a valid license key for each product. The 
license keys are included in the license file emailed to you by Thermo-Calc Software.

You can copy the license file to the applicable computer(s) before or after installing the 
software––the license file itself is not required during the installation process. However, it is 
required to make calculations in Thermo-Calc. 

"Request a License File from Thermo-Calc Software" on page 66  
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Standalone Installations (SUNLL)
The standalone installation is used with the Single-User Node-Locked License (SUNLL). The 
Thermo-Calc software  and a Thermo-Calc license file   are installed on a standalone 
computer. You can do a full (all operating systems) or a custom installation (Windows and Linux 
only).

To get started, go to "First Steps of Installation" on page 20 and then "Standalone 
Installations" on page 34.
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Multi-User Network Installations (NWL)
There are different types of multi-user network installations: consolidated, distributed, and 
where the licensing software is installed on a computer network. There is also a subtype of 
installation called thin client, which is a step done with the consolidated and distributed 
network installations.

Thin client installations: A thin client installation is where the Thermo-Calc 
software is installed on a computer server but is run from a client computer. The 
licensing software can be installed on the computer server (a consolidated 
network) or on a different computer (a distributed network). This type of 
installation is available for Windows and Linux operating systems. The client 
computer must have the Thermo-Calc software installed. This type of installation 
mainly sets environmental variables and paths on the client computer.

Consolidated Network Installations

The consolidated network installation is used with a Network License (NWL) and it is available 
for Windows and Linux operating systems.

The Thermo-Calc software  and the license management program are installed on the same 
server where the license file   is also copied. A thin client installation allows all computers 
(the clients) in the server network to access both the software and the licensing on the same 
computer server.
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To get started, go to "First Steps of Installation" on page 20 and then "Network 
Client Installations" on page 43.

Distributed Network Installations 

The distributed network installation is used with a Network License (NWL) and is available for 
Windows and Linux operating systems. 

The Thermo-Calc software  is installed on one computer server in a network and the 
licensing software is installed on a different computer server where the license file   is also 
copied. A thin client installation allows all computers (the clients) in the server network to 
access both the software and the licensing on the two computer servers.

To get started, go to "First Steps of Installation" on page 20 and then "Network 
Client Installations" on page 43.

License Installations on a Server Network 

When a license file is installed on a server network, it is used with a Network License (NWL). It 
is available for all platforms. However, for macOS the server containing the licensing software 
must be set up on Windows or Linux.
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The licensing software is installed on a computer server where the license file   is also 
copied. The Thermo-Calc software  is installed on every computer in the network that needs 
it. 

To get started, go to "First Steps of Installation" on page 20 and then "Network 
Client Installations" on page 43.
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First Steps of Installation
This section reviews some of the things you need to do before installing the Thermo-Calc 
software. 

 l Learn about the different default directories where the software and license files are 
installed.

 l For network installations, collect subnet information.

 l Make sure the person installing the software has administrator rights for Windows and 
macOS.

 l For macOS, install XQuartz and make sure the security preferences are set correctly.

 l For a Linux Cent OS 7 installation, also install gtk2 before you run the installation script.

yum install gtk2

Should I get my license file before or after software installation? The 
Thermo-Calc license file itself is not required during the installation process. 
However, it is required to make calculations in Thermo-Calc. The license file has 
details about your computer(s) that in some cases cannot be determined 
accurately until after installation (especially for a network installation). For most 
users it is recommended you request the file before you start installing.
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Installation Default Directories and the License File 
The default directories where the software and its components are installed, including where 
the license file is stored, vary by platform and user type. 

If you want to select specific components to install or if you want to install the software in a 
non-default installation directory, then do a custom installation (Windows and Linux only). In 
the table, <user> stands for the user name and <version> for the version of Thermo-Calc, for 
example 2023a.

License File Installation Location for All Operating Systems
The Thermo-Calc license file is installed outside of the installation program folder. If you have 
more than one version of Thermo-Calc installed then there are additional folders by version 
number with only one license file. 

For macOS the license file is put in /Users/Shared/Thermo-Calc. The example below is for a 
Standalone Windows installation. 

See the following for more information:

 l "Installation Default Directory: Windows" on the next page

 l "Installation Default Directory: macOS" on page 23

 l "Installation Default Directory: Linux" on page 24

 l "Installation Default Directory: Databases, Database Checker, and TDB Editor" on 
page 25

 l "Installation Default Directory: Materials" on page 27

 l "Installation Default Directory: Process Metallurgy Materials" on page 28

 l "Installation Default Directory: Custom Property Models" on page 29

 l "Installation Default Directory: TC-Python" on page 93

 l "Installation Default Directory: TC-Toolbox and the Examples" on page 102
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Installation Default Directory: Windows

Administrative rights are required to install and uninstall Thermo-Calc. 

Windows User 
Type

Default Directory

Administrator

The Thermo-Calc program is installed here: 

Program Files\Thermo-Calc\<version>

The default folders where documents, materials files, examples, and other folders that sometimes 
require additional licenses are installed under Public Documents for ALL USERS. 

For a local user these files are copied to the user’s Documents folder where this local copy is 
associated to the user login. The Public Documents folder always contains the original set of 
contents as per the installation.

C:\Users\Public\Public Documents\Thermo-Calc\<version>

After installing Thermo-Calc, and when you first open the program, the set of folders is copied from 
the source Public Documents location into a user Documents folder:

C:\Users\<user>\Documents\Thermo-Calc\<version>

It is recommended that you work with the files that are copied to the user folder.

In some cases when an interim software update is installed there is also a backup 
folder created in this folder. For details, see "Updating the Software for Interim 
Releases" on page 143.

Server network
License software installations on a server network (the License Manager software)

C:\Program Files (x86)\Common Files\SafeNet Sentinel\Sentinel RMS License 
Manager\WinNT\
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Installation Default Directory: macOS

macOS User Type Default Directory

Administrator (user 
name and password 
required)

The Thermo-Calc program is installed in the Applications folder: 

Thermo-Calc-<version>.app and uninstall-Thermo-Calc-<version>.app

The documents, materials, examples, and other folders that sometimes require additional 
licenses are installed here: 

/Users/Shared/Thermo-Calc/<version>

In some cases when an interim software update is installed there is also a 
backup folder created in this folder. For details, see "Updating the Software 
for Interim Releases" on page 143.

To go to this folder, in Finder, from the Go main menu select Go to folder. Enter the above 
file path and click Go.
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Installation Default Directory: Linux

Linux User Type Default Directory

Non root user
The Thermo-Calc program including the documents, materials, examples, and 
other folders that sometimes require additional licenses are installed here:

/home/<user>/Thermo-Calc/<version>

Root user

The Thermo-Calc program including the documents, materials, examples, and 
other folders that sometimes require additional licenses are installed here:

/opt/Thermo-Calc/<version>

In some cases when an interim software update is installed there 
is also a backup folder created in this folder. For details, see 
"Updating the Software for Interim Releases" on page 143.

License software installations on a 
server network (the License Server 
software) 

If you are doing a network installation then these files are available as a tar-file 
from the Thermo-Calc website. Contact Support for more information.

In the downloaded tar-file, there is a restart_lserv script file, which can be used as 
a template for creating a script that starts up the License Server.

https://thermocalc.com/support/
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Installation Default Directory: Databases, Database 
Checker, and TDB Editor
The standard Thermo-Calc databases and the database initialization file tc_initd.tdb are 
located in a subfolder to the Thermo-Calc installation. For example, in a Windows Standalone 
installation, you can find these in a folder called data where the file path is C:\Program 
Files\Thermo-Calc\<version>\data.

Database Checker

The Thermo-Calc software package includes a program to check that the syntax of unencrypted 
database files is correct. The program applies the syntax rules set out in the Database Manager 
User Guide and reports errors and issues warnings. This program is intended for advanced users 
who develop and manage databases. 

Thermo-Calc  accepts some deviations from these syntax rules. Although warnings 
can be ignored, errors must be corrected. Reported errors must be corrected in 
the TDB file before the database can be loaded by the application. Sometimes the 
warnings can also reveal the need for additional corrections as shown in the 
example below. 

For example,  a warning is generated if a phase name is detected that is also an abbreviation of 
another phase name in the database. Although allowed, it is not recommended as this can (in 
some cases) lead to unexpected results because abbreviations are also used  when entering 
commands in the Console and included in macro files. The following shows why in this case an 
abbreviation is not recommended. 

Imagine that a macro file uses the abbreviation ABC to refer to a phase in a database that is 
named ABCDE. As long as there is no other phase in the database with the same exact name or 
initial abbreviation, it works. But if a new phase is added to the database and is actually named 
ABC then the macro can in error refer to the wrong phase. The macro still runs but now refers 
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to the phase ABC instead of ABCDE because ABC is an exact match, which takes precedence over 
abbreviations.  The Database Checker displays a warning because this situation can only occur 
when one phase name is an abbreviation of another.

With respect to using this tool, the executable DatabaseChecker file is found in the 
Thermo-Calc home directory. The program can also be launched by selecting Tools → Database 
Checker from the main menu in Thermo-Calc.

TDB Editor

The TDB Editor is an editing tool for those who develop their own custom databases for use 
with Thermo-Calc or other applications. The tool speeds up the database editing process by 
providing immediate feedback through syntax coloring, syntax checking, and by allowing 
formatting and easy navigation to items of interest in the TDB file.  

During installation, the tdb-language-support.vsix file is installed in the Thermo-Calc home 
directory. 

In order to access the most-up-to-date version of the VSCode plugin, it must be 
updated every time a new version of Thermo-Calc is installed. 

For information about installing the TDB Editor, which is separate from the main 
installation and can be done later, see the Database Manager's User Guide 
contained in the Thermo-Calc Documentation Set or press F1 in Thermo-Calc and 
search the help.
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Installation Default Directory: Materials
When you are working with the System Definer or Material to Material Calculator you can open 
the default  Materials folder included with your installation. 

At the bottom of the window under Material, click Load material to navigate to a material file. 

There is a separate folder for materials saved using the Process Metallurgy 
Calculator. See "Installation Default Directory: Process Metallurgy Materials" on 
the next page.

The default directory where these material files are stored is based on operating system:

Operating System Materials Installation Directory

Windows C:\Users\<user>\Documents\Thermo-Calc\2023a\Materials

Linux
On Linux all user files are installed where the program is installed. If installed as root the default 
is:

/opt/Thermo-Calc/2023a/Materials

macOS /Users/Shared/Thermo-Calc/2023a/Materials
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Installation Default Directory: Process Metallurgy 
Materials
With the Process Metallurgy Calculator you can save materials to work with again. This is the 
default folder where these are stored based on your operating system:

Operating System Process Metallurgy Materials Installation Directory

Windows C:\Users\<user>\Documents\Thermo-Calc\2023a\ProcessMetallurgyMaterials 

Linux
On Linux all user files are installed where the program is installed. If installed as root the 
default is:

/opt/Thermo-Calc/2023a/ProcessMetallurgyMaterials

macOS /Users/Shared/Thermo-Calc/2023a/ProcessMetallurgyMaterials
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Installation Default Directory: Custom Property Models

All Property Models (whether these are predefined or custom models) must be 
located in a subdirectory of the Property Model directory. You can go to Tools → 
Options and the Model directory field displays the default directory.

Predefined models included with the Property Model Calculator are installed in the locations 
below based on your operating system. If you create your own models using TC-Python, this is 
the default directory where these are saved. 

Operating System Property Model Installation Directory

Windows C:\Users\<user>\Documents\Thermo-Calc\2023a\PropertyModels

Linux
On Linux all user files are installed where the program is installed. If installed as root the 
default is:

/opt/Thermo-Calc/2023a/PropertyModels

macOS /Users/Shared/Thermo-Calc/2023a/PropertyModels
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Subnet Information for Network Licenses
This is related to "Full Network Client Installations" on page 44.

For network licenses, the subnet information is also required. Ask your network administrator 
for the network address for the subnet. Additional requirements are included elsewhere for 
network installations.

 l Subnets should be in the format aaa.bbb.ccc*** (for example: 192.168.29.0/24 or 
192.168.29.* 

 l When installing on Sentinel RMS License Server version 9.7, a maximum of seven (7) 
subnets are permitted.

An alternative way to get this information is to run the command:

 l Windows: ipconfig /all  

 l macOS/Linux: ip a  
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macOS Installation Notes

How to Restart After an Installation

In some types of installations (e.g. a network installation), you may have to restart your Mac to 
use Thermo-Calc for the first time. 

How to Install XQuartz

The XQuartz open-source X Windows system is required to run Thermo-Calc on macOS  but it is 
not required to install Thermo-Calc. Before installing Thermo-Calc, you may also need to ensure 
that the computer security permissions are set.

 1. In a web browser go to https://www.macupdate.com or to download it directly from 
XQuartz, http://xquartz.macosforge.org/landing/.

 2. In the Search Mac Apps field, enter XQuartz.

 3. Click the XQuartz search result. For example, based on the recent version, the name is 
XQuartz-2.7.11.dmg.

 4. Click Download. 

 5. Double-click the XQuartz.pkg file. Follow the instructions.

 6. Click OK when the message about logging out displays and click Close when the installation 
is successful.

How to Enable the Security Settings

 1. From the Apple main menu, select System Preferences.

 2. Click Security and Privacy.

 3. Click General. At the bottom of the Security & Privacy window, click the lock icon to make 
changes. Enter the administrator password as required.

 4. If you have already tried to launch the Thermo-Calc installer, you can click Open Anyway 
to proceed. Otherwise, under Allow apps downloaded from: click Anywhere and then 
Allow from Anywhere.

 5. Continue with the applicable installation type (standalone or network). 

https://www.macupdate.com/
http://xquartz.macosforge.org/landing/
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Remember to reset your security after installing Thermo-Calc.
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Linux Installation Notes
The following are details you need to know regarding your Linux installation as well as how to 
open Thermo-Calc.

openSUSE Administration (sudo) Users 

Note the following if you are a sudo user (administrator) in openSUSE installing Thermo-Calc 
using this command:

sudo ./linux-installation-x64-6.0.0.17347.run

When this command is used, you will do a text-based installation instead of having a graphical 
interface to guide you. The information  is the same, just without the user interface. 

Opening Thermo-Calc in Linux

To open Thermo-Calc double-click the Thermo-Calc-2023a application or from the Thermo-Calc 
installation directory enter $ ./Thermo-Calc-2023a.sh in the terminal.
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Standalone Installations
You can either do a full or a custom standalone installation. The license type is called a Single-
User Node-Locked License (SUNLL).

In this section:

Full Standalone Installations 35

Custom Standalone Installations 39

Add New Components to an Existing Installation 42



Standalone Installations

Full Standalone Installations ǀ 35 of 150

Full Standalone Installations
The following describes a full standalone installation. These steps assume you have completed 
the section "First Steps of Installation" on page 20.

Step 1. Request your License File from Thermo-Calc Software

Updates to Thermo-Calc: Customers who subscribe to the annual maintenance 
plan can skip this step if you have received your license file in an email from 
Thermo-Calc Software AB. Save the license file to your computer to use during 
software installation. The license file name must be the same as the existing file 
name to ensure there are no errors during the update.

Follow the instructions for your operating system in the section "Request a License File from 
Thermo-Calc Software" on page 66. 

Step 2. Download your Thermo-Calc Installation Software

 l Web downloads: For web links sent in an email from Thermo-Calc Software, go to the 
URL and log in with the information provided to download the software.

 l DVD installations: Insert the DVD and follow the instructions. 

Step 3. Run the Applicable Installation File for your Operating 
System

 1. Navigate to the folder for your operating system and click the link to download the 
software package, then go to the folder where you downloaded it. 

Administrative rights are required for Windows and macOS installations. 

Windows

Right-click the .exe file and choose Run as administrator to launch the Setup program. 
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macOS

Double-click the downloaded file then follow the instructions.

For macOS and when you first run the installer, you may see a message that 
Thermo-Calc-osx-<version> can't be opened because Apple cannot check it for 
malicious software. If this happens, select Show in Finder. Then, in the opened 
Finder window right-click the downloaded file Thermo-Calc-osx-<version> and 
select Open.

Linux

To start the Setup Wizard in a Terminal window, enter these commands in the directory where 
the installation file is saved: 

> chmod +x linux-installation-x64-2023a.run

> ./linux-installation-x64-2023a.run

If you are an openSUSE root user, see "Linux Installation Notes" on page 33 for 
some information about your installation.

 2. On the Setup window click Next. 

 3. On the License Agreement window click the button to accept the license agreement 
then click Next. 

Step 4. Select the Installation Type and Upload the License File

"About the Thermo-Calc Components Being Installed" on page 8
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 1. In the Select Installation Mode window click Full Standalone: Install all features. 

If you want to exclude a component (e.g. an SDK), then  use the Custom 
option. See "Custom Standalone Installations" on page 39. For TC-Toolbox 
for MATLAB®, also see "Installing TC-Toolbox with the Custom Option" on 
page 105.

TC-Python is installed when the Full Standalone or Full Network Client 
option is chosen, but there are additional steps required as described 
separately for this SDK. 

 2. For a Full Standalone installation, in the Choose a license file field either enter the file 

path or click the file button  to navigate to where you saved the license file emailed 
to you from Thermo-Calc Software. The license file is called lservrc. 

To prevent errors, leave this field blank if you did not get a license file yet. 

TC-Python is installed for all users even without a license. The Install TC-Python window  
is a reminder that additional installation procedures are required after Thermo-Calc is 
installed.
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Step 5. Install the Software and Start Using Thermo-Calc

 1. In the Ready to Install window click Next.

See the separate instructions for TC-Toolbox for MATLAB®.

 2. Click Finish and start using Thermo-Calc. For Linux users, log out and log back in to 
finish the installation.

macOS installations and if you have previous Thermo-Calc installations: 
When you launch Thermo-Calc with the new or updated version, the splash 
screen hides the Import User Settings dialog box. In order to proceed you 
need to click the splash screen and then click Yes or No in the dialog box. 

If you did not get your license file see "Request a License File from 
Thermo-Calc Software" on page 66.
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Custom Standalone Installations
"About the Thermo-Calc Components Being Installed" on page 8

Use the Custom option to have more control over what component features to include or 
exclude, for example, to exclude an SDK.  

This topic describes how to do a custom installation on a standalone computer for either a 
Windows or Linux operating system. These steps assume you have completed these sections:

 l "First Steps of Installation" on page 20 

 l Steps 1 to 3 of a "Full Standalone Installations" on page 35 where you  request your 
license file, download the software and then have started to set up the program up to 
the Select Installation Mode window.

Step 1. Select the Installation Mode and the Components to Include 
or Exclude 

"About the Thermo-Calc Components Being Installed" on page 8

 1. In the Select installation mode window click Custom (the option appears greyed out, 
but it is available to select). Click Next.

 2. On the Specify Configuration window the Create Shortcut on Desktop check box is 
selected by default. Click Next.
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 3. In the Select Components window, click to select or deselect the check boxes as 
needed. Click Next.

 

Step 2. Set the Installation Directory and Choose the License File

 1. In the Installation Directory window, either accept the default path or enter a path to 
where you want to install the software (see "Installation Default Directories and the 
License File " on page 21). Click the file button  to Browse for Folder and navigate to 
another directory. 

To prevent errors, leave this field blank if you do not have a license file yet. 

 2. In the Choose Setup Type window, click Standalone.
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 3. In the Choose a license file field enter the path to your license file (called lservrc) or 
click the file button  to navigate to a location on the computer and open the file. 

 4. TC-Python is installed for all users even if you do not have a license. The Install TC-
Python window  is a reminder that additional installation procedures are required after 
Thermo-Calc is installed. See the TC-Python Installation Guide for details.

Step 3. Install the Software and Start Using Thermo-Calc

 1. In the Ready to Install window click Next.

See the separate instructions for TC-Toolbox for MATLAB®.

 2. Click Finish and start using Thermo-Calc. For Linux users, log out and log back in to finish 
the installation.

macOS installations and if you have previous Thermo-Calc installations: When you 
launch Thermo-Calc with the new or updated version, the splash screen hides the 
Import User Settings dialog box. In order to proceed you need to click the splash 
screen and then click Yes or No in the dialog box. 

If you did not get your license file see "Request a License File from Thermo-Calc 
Software" on page 66.
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Add New Components to an Existing Installation
If you want to add new components to an existing Thermo-Calc installation (for example, you 
purchased a license for TC-Toolbox for MATLAB®), run the  installation file again as in Step 3 of 
"Full Standalone Installations" on page 35. 

 1. For all OS you need to have administrative level rights. For example in Windows, right-
click the executable Thermo-Calc installation .exe file and choose Run as administrator 
to launch the Setup program. 

 2. Click Next. Click to accept the license agreement. 

 3. Select the additional component(s) to install.  

 4. Click Next to start the installation, which adds the new component(s). 

Use the Uninstall program to remove components. See "Uninstalling Thermo-Calc" 
on page 149 or "Uninstalling TC-Toolbox for MATLAB®" on page 112.



Network Client Installations

Network Client Installations ǀ 43 of 150

Network Client Installations
This installation type is available for all operating systems, however for macOS the License 
Server must be run on a Windows or Linux computer. It is applicable to the consolidated and 
distributed network types of installations as well as for the licensing installation on a server 
network.

"About the Thermo-Calc Components Being Installed" on page 8

In this section:

Full Network Client Installations 44

Windows: About Installing the License Manager 46

Windows: Installing the Sentinel RMS License Manager 48

Linux: About Installing the License Server 51

Linux: Installing the Sentinel RMS License Server 54

Thin Client Installations 57

Custom Network Client Installations 60

Unattended Network Client Installations 63
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Full Network Client Installations
The following outlines how to do a full network client installation. 

Step 1. Install the Sentinel RMS Management License Software

Follow the instructions for your operating system:

Windows

 l "Windows: About Installing the License Manager" on page 46

 l "Windows: Installing the Sentinel RMS License Manager" on page 48

Linux

 l "Linux: About Installing the License Server" on page 51

 l "Linux: Installing the Sentinel RMS License Server" on page 54

Step 2. Complete Steps 1 to 3 of a Full Standalone Installation

These steps assume you have completed the instructions for "Full Standalone Installations" on 
page 35 to download and run the software up to the Select Installation Mode window. It is up 
to you whether you get the computer information for the license files before or after installing 
the software.

Step 3. Choose the Installation Type and Enter the Computer Server 
Details

"About the Thermo-Calc Components Being Installed" on page 8

 1. In the Select Installation Mode window click Full Network Client to Install all features 
(the option appears greyed out, but it is available to select). 

If you want to exclude a component (perhaps one of the SDKs), then use 
the Custom option and see "Custom Network Client Installations" on 
page 60.
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 2. In the field, enter the name or IP number of the computer where the licensing software 
is installed. Click Next. 

 3. TC-Python is installed for all users even if you do not have a license. The Install 
TC-Python window  is a reminder that additional installation procedures are required 
after Thermo-Calc is installed. See the TC-Python Installation Guide for details.

 4. In the Ready to Install window click Next. 

 5. When the Completing the Thermo-Calc Setup Wizard window opens, click Finish. For 
Linux users, log out and log back in to start using Thermo-Calc. 

macOS installations and if you have previous Thermo-Calc installations: 
When you launch Thermo-Calc with the new or updated version, the splash 
screen hides the Import User Settings dialog box. In order to proceed you 
need to click the splash screen and then click Yes or No in the dialog box. 

If you did not get your Thermo-Calc license file see "Request a License File from 
Thermo-Calc Software" on page 66.
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Windows: About Installing the License Manager

If you have previously installed an older version of Sentinel RMS License Manager, 
you must first uninstall the old version then reboot the server before starting with 
a new installation.

The Sentinel RMS License Manager service supplies the client computers in your network with 
license tokens when it runs Thermo-Calc software. The Sentinel RMS License Manager software 
is installed on a computer that acts as a license server in your network. This is related to "Full 
Network Client Installations" on page 44 and administrative rights are required for all steps.

Remember to collect subnet information before beginning. See "Subnet 
Information for Network Licenses" on page 30.

A network license can only be used on one specific computer that hosts the 
License Manager. The network license determines which client computers receive 
license tokens using the IP addresses and IP ranges.

Supported Windows Versions

These Windows operating systems are supported for the installation of Sentinel RMS License 
Manager. When ready, go to "Windows: Installing the Sentinel RMS License Manager" on 
page 48.

For macOS, the Sentinel RMS License software is installed on a Windows  or Linux  
computer server where the Thermo-Calc license file must also be located. 
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Windows 32-bit Operating Systems

 l Windows 7

 l Windows 8.1

 l Windows 10 v1909

 l Windows Server 2008

Windows 64-bit Operating Systems

 l Windows 7

 l Windows 8.1

 l Windows 10 v1909

 l Windows Server 2008

 l Windows Server 2008 R2

 l Windows Server 2012

 l Windows Server 2012 R2

 l Windows Server 2016

 l Windows Server 2019 
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Windows: Installing the Sentinel RMS License Manager

First review "Windows: About Installing the License Manager" on page 46. Then if 
this is a new installation of the Sentinel RMS License Manager, start with Step 2.

Step 1. Uninstall Any Older Versions of Sentinel RMS License 
Manager

 1. With Administrator rights, log onto the server that hosts the Sentinel RMS License 
Manager.

 2. Save a copy of the license file LSERVRC found in the default directory—the license file 
can be saved as a text file: C:\Program Files (x86)\Common 
Files\SafeNetSentinel\Sentinel RMS License Manager\WinNT\. 

After saving the existing license file and uninstalling the old version of 
Sentinel RMS, ensure you delete the old license file (LSERVRC) in the above 
folder.  This license is not required anymore.

 3. Reboot the computer hosting the Sentinel RMS License Manager.

 4. Continue with the installation and use the preselected default settings.

Step 2. Download and Install Thermo-Calc

This step is not required to complete the server installation, however some administrators may 
want to do it at this point.

 1. Download Thermo-Calc. 

 l Web downloads: For web links sent in an email from Thermo-Calc Software, go 
to the URL and log in with the information provided to download the software.

 l DVD installations: Insert the DVD and follow the instructions. 

 2. Install Thermo-Calc. For testing purposes, and in order to confirm the installation is 
working correctly, install the Thermo-Calc software on the same computer as the 
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Sentinel RMS License Manager. If required after testing, Thermo-Calc can always be 
uninstalled. 

Step 3. Install the Sentinel RMS License Manager Software

 1. From the download, extract the files license_server_win_9.7.zip and LS_tools_
win.zip.

 2. Right-click setup.exe and select Run as Administrator from the menu.

Step 4. Choose the Installation Directory

 1. Click to accept the license agreement. 

 2. Enter your User Name and Organization and select to install the License Manager for All 
users. 

 3. In the Destination Folder window click Next to accept the suggested destination 
directory or Change to select another directory. 

Step 5. Choose the Setup Type and Install the Software

 1. In the Setup Type window, select Complete. Click Next. 

 2. Select the Unblock the system firewall for the Sentinel RMS License Manager check 
box.

Selecting the check box is required to run Thermo-Calc.

 3. Click Next and then Install.

 4. Click Finish to exit the InstallShield Wizard.

Step 6. Install the Thermo-Calc Network License Using WIAdmin

Only the WlAdmin tool can be used to update the network license used by the 
License Manager.
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 1. Save the source file containing the license code. The source file can be kept as a .txt file

 2. Go to the previously saved file LS_tools_win.zip.

 3. Right-click the file WlmAdmin.exe and select Run as Administrator from the menu.

 4. If the license server is not found under subnet servers, go to Edit → Defined Server List. 

 5. Enter the host name or IP address of the license server.

 6. Click Add and then OK.

 7. Click View → Refresh All to update the list.

 8. In the left main window right-click the name of a License Manager.

 9. From the menu select Add Feature → From a File → To Server and its File.

 10. To add the license from a file, select From a File. This permanently adds the license code 
to the License Manager license file as well as to the License Manager memory.

 11. In the windows that open, browse to the source file that contains the license code and 
click Open.

Step 7. Install Additional Tool Options

"Sentinel RMS License 9.7 Tools" on page 125
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Linux: About Installing the License Server
The Sentinel RMS License Server service supplies the client computers in your network with 
license tokens when it runs Thermo-Calc software. The Sentinel RMS License Server software is 
installed on a computer that acts as a license server in your network. This is related to "Full 
Network Client Installations" on page 44. 

Preparing for Installation

Read and be aware of the following before you begin the section "Linux: Installing the Sentinel 
RMS License Server" on page 54.

Remember to collect subnet information before beginning. See "Subnet 
Information for Network Licenses" on page 30.

Uninstall Older Versions of the License Server

 l Older versions of the License Server must be stopped by with  lsrvdown before running 
the new installation. This is Step 1 in "Linux: Installing the Sentinel RMS License Server" 
on page 54.

 l If you have a license server: Upgrade your license server if the new one is a higher 
version than the present one. Clients work with newer license servers (managers) but 
not necessarily with ones older than the client.

Requires Root Access or  sudoers List

Root access to your computer is required or you need to be on the sudoers list.

Linux 32-bit Installations on a 64-bit OS

To run a license server 32-bit on a Linux 64-bit OS, 32-bit library support is needed.
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Thermo-Calc License File

The name of the license file must be in lower case letters (lservrc) because Linux 
commands and operations are case-sensitive.

 l You need a valid lservrc network license file supplied by Thermo-Calc Software 
("Requesting the License File for Windows or Linux" on page 68) as well as the actual 
License Server—a file (program) called lserv. 

 l The Thermo-Calc license file needs to be readable and writable by the license server 
(license manager).

Differences Between 32- and 64-bit Scripts

Sentinel RMS License Server version 9.7 supports both 32- and 64-bit. However, when writing 
scripts be aware of script naming and do not mix the scripts.

 l All 32-bit scripts are named <script_name>, for example restart_lserv

 l All 64-bit scripts are named <script_name>64, for example, restart_lserv64

It is not possible to use Linux 32-bit scripts/tools to manage license server 64-bit 
and vice versa, you cannot use Linux 64-bit scripts/tools to manage license server 
32-bit

openSUSE Administration (sudo) Users 

Note the following if you are a sudo user (administrator) in openSUSE installing Thermo-Calc 
using this command:

sudo ./linux-installation-x64-6.0.0.17347.run

When this command is used, you will do a text-based installation instead of having a graphical 
interface to guide you. The information  is the same, just without the user interface. 
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Supported Linux Operating Systems and Versions

For macOS, the Sentinel RMS License software is installed on a Windows  or Linux  
computer server where the Thermo-Calc license file must also be located. 

Both Linux 32-bit and 64-bit operating systems are supported for the installation of Sentinel 
RMS License Server.

 l Red Hat Enterprise Linux (RHEL) 7.x

 l Red Hat Enterprise Linux (RHEL) 8.x

 l SUSE Linux Enterprise Server (SLES)12.x

 l SUSE Linux Enterprise Server (SLES) 15.x

 l Debian Linux 9.x

 l Debian Linux 10.x

 l Ubuntu Linux 16.x (LTS)

 l Ubuntu Linux 18.x (LTS)

 l Ubuntu Linux 20.x (LTS)

 l OpenSUSE Leap 42.x

 l OpenSUSE Leap 15.x
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Linux: Installing the Sentinel RMS License Server

First review "Linux: About Installing the License Server" on page 51. Then if this is a 
new installation of the Sentinel RMS License Server, start with Step 2.

Sentinel RMS License Server version 9.7 supports both 32- and 64-bit. However, when writing 
scripts be aware of script naming and do not mix the scripts.

 l All 32-bit scripts are named <script_name>, for example restart_lserv

 l All 64-bit scripts are named <script_name>64, for example, restart_lserv64

It is not possible to use Linux 32-bit scripts/tools to manage license server 64-bit 
and vice versa, you cannot use Linux 64-bit scripts/tools to manage license server 
32-bit

Step 1. Stop Older Versions of the Sentinel RMS License Server 

 1. To  stop an old version of the License Server  already running, go to the directory where 
the old file is found, and enter the commands:

 l 32-bit license server

>chmod +x <lsrvdown>

>./lsrvdown <host_name>

 l 64-bit license server

>chmod +x <lsrvdown64>

>./lsrvdown64 <host_name>

 2. Edit existing scripts that start the older version of the License Server so that they start 
the newer version instead. 

For more information about the lservdown utility, go to http://sentinelrms.safenet-
inc.com/RMSDocumentation/SysAdmin/Content/lsrvdown.htm

http://sentinelrms.safenet-inc.com/RMSDocumentation/SysAdmin/Content/lsrvdown.htm
http://sentinelrms.safenet-inc.com/RMSDocumentation/SysAdmin/Content/lsrvdown.htm
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Step 2. Write a Script to Start the License Server

The following is an excerpt from the template script for starting the License Server found in the 
restart_lserv file. 

Replace the paths for LICENSE_SERVER_DIR, LICENSE_FILE_DIR and LOG_DIR to match your 
system. Save it as a script:

# set the directory where the executables are located

LICENSE_SERVER_DIR=/usr/local/Thermo-Calc/2023a/Licensing-files

# set the directory of the license file lservrc

LICENSE_FILE_DIR=/usr/local/Thermo-Calc/2023a/Licensing-files

# set the directory where you wish to save the log-files

LOG_DIR=/tmp

# stop the running server

# (omit this line if calling this script at startup)

$LICENSE_SERVER_DIR/lsrvdown $HOSTNAME

# start the license server

$LICENSE_SERVER_DIR/lserv -s $LICENSE_FILE_DIR/lservrc -l $LOG_DIR/lserv_use.log -f 
$LOG_DIR/lserv_err.log

Step 3. Confirm the HOSTNAME variable and open the UDP port

The hostname should always correspond to the DNS record verify this by doing the following.

 1. Before starting the License Server make sure that the value of the $HOSTNAME variable 
is correct. This value can be shown by typing the > nslookup $HOSTNAME command in 
the terminal window:

The value should be the same IP address that is shown when you use the ifconfig 
command. 

 2. Open the UDP port 5093 in your firewall. In case you have installed SELinux you might 
also need to disable it by setting SELINUX=permissive in the /etc/selinux/config file.

Step 4. Start the License Server

 1. To start the License Server, run the script created as root. Enter these commands in the 
console:

> chmod +x <name_of_script_file>

> ./<name_of_script_file>
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 2. If you want the License Server to start when you boot the system, put a copy of the start 
script under /etc/rc.d/init.d and start the script from the file /etc/rc.d/rc.local.

Step 5. Install Additional Tool Options

"Sentinel RMS License 9.7 Tools" on page 125
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Thin Client Installations
This topic describes how you install a thin Thermo-Calc client to run Thermo-Calc from a file 
server. It is applicable to consolidated and distributed network installations for either a 
Windows or Linux operating system.

Installation Requirements

 l You need access to the directory where Thermo-Calc is installed on the file server. 

 l You need the IP number or name of the computer where the license file is installed.

 l For Linux you may have to disable your firewall. If SELinux is installed, try disabling it by 
setting SELINUX=permissive in /etc/selinux/config.

Windows Installations 

The following details may also be of use to those installing in a Windows environment.

 l Requests license server name or address and sets LSHOST as a user environment 
variable accordingly.

 l Sets TC<version>_HOME (where <version> is the software version, e.g. TC22A_HOME) as 
a user environment variable to point to the location from which the thin client installer 
is running.

The default folders where documents, materials files, examples, and other folders 
that sometimes require additional licenses are installed under Public Documents 
for ALL USERS. See "Installation Default Directory: Windows" on page 22. 

How to Install a Thin Client on Windows 

 1. Map the file server share as a network drive so that it gets an assigned drive letter (e.g. 
E:).

 2. Open the \Thermo-Calc\<version>\ directory on the file server, where version is the 
current version of the software.

 3. Open the directory Thin-client. Double-click the Thermo-Calc-client-windows-
<version>.exe file.
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 4. Click to accept the terms of the license agreement. Click Next.

 5. Enter the name or IP number of where the license file and the License Manager 
software is installed. Click Next.

 6. By default the Create Shortcuts on Desktop check box is selected. Click Next. 

The shortcuts to the program are added to the user's Windows roaming 
profile as well as placed on the user's Desktop (not the system's).

 7. In the Ready to Install window, click Next. 

 8. Click Finish. To start Thermo-Calc find the program on the server and start it from there. 

How to Install a Thin Client on Linux

 1. Add the following to the smb.conf file, where <user> is your user name:
[public]

path=/home/<user>/Thermo_Calc/2023a

public=yes

writable=yes

comment=smb share

guest OK=yes

force user=<user>

 2. From the client, mount the directory on the server computer that contains the 
Thermo-Calc server installation (by default, this directory is called 
/Thermo-Calc/2023a). How the directory is mounted depends on the Linux distribution 
being used as well as how the Thermo-Calc directory on the server computer is shared. 
Use the Linux command mount. For example:

> mkdir public

> sudo mount -t cifs //ip_number_server_computer/public ./public -o 
user=<user>

 3. Open the mounted directory on your computer, and run client-install-linux-
x64.run or client-install-linux-x86.run in the /Thin-client directory. 



Network Client Installations

Thin Client Installations ǀ 59 of 150

 4. If you do this from the terminal window, use the following to start the installation 
(assuming that the file server is a 64-bit computer):

> ./client-install-linux-x64.run 

 5. Click Forward and click to select the license agreement. Click Forward.

 6. Enter the name or IP number of the License Server. Click Forward. 

 7. If you are installing as a non-root user, by default, the Create Shortcuts on Desktop 
check box is selected. Click Forward.

 8. In the Ready to Install window click Forward. 

 9. Click Finish. Log out and log back in to start using Thermo-Calc.
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Custom Network Client Installations
This installation type is available for all operating systems, however for macOS the License 
Server must be run on a Windows or Linux computer.The requirements are the same as for a 
full client installation.

Step 1. Install the Licensing Software

Follow the instructions for your operating system:

 l "Windows: About Installing the License Manager" on page 46, or

 l "Linux: About Installing the License Server" on page 51

Step 2. Complete Steps 1 to 4 of a Full Standalone Installation

Follow the instructions for "Full Standalone Installations" on page 35 to download and run the 
software. It is up to you whether you get the computer information for the license files before 
or after installing the software.

Step 3. Select the Installation Mode and the Components to Include 
or Exclude 

"About the Thermo-Calc Components Being Installed" on page 8

 1. In the Select installation mode window click Custom (the option appears greyed out, 
but it is available to select). Click Next.

 2. On the Specify Configuration window the Create Shortcut on Desktop check box is 
selected by default. Click Next.
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 3. In the Select Components window, click to select or deselect the check boxes as 
needed. Click Next.

 

Step 4. Set the Installation Directory and the File Path to the License

 1. In the Installation Directory window, either accept the default path or enter a path to 
where you want to install the software (see "Installation Default Directories and the 
License File " on page 21). Click the file button  to Browse for Folder and navigate to 
another directory. Click Next. 

To prevent errors, leave this field blank if you do not have a license file yet.
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 2. In the Choose Setup Type window, click Network Client and enter the name or IP 
number of the computer where the licensing software is installed. Click Next.

If you have selected to install TC-Python there is a reminder window that 
additional installation procedures are required after Thermo-Calc is 
installed. See the TC-Python Installation Guide.

Step 5. Install the Software and Start Using Thermo-Calc

 1. In the Ready to Install window click Next.

See the separate instructions for TC-Toolbox for MATLAB®.

 2. Click Finish and start using Thermo-Calc. For Linux users, log out and log back in to finish 
the installation.

macOS installations and if you have previous Thermo-Calc installations: When you 
launch Thermo-Calc with the new or updated version, the splash screen hides the 
Import User Settings dialog box. In order to proceed you need to click the splash 
screen and then click Yes or No in the dialog box. 

If you did not get your license file see "Request a License File from Thermo-Calc 
Software" on page 66.
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Unattended Network Client Installations

Terminology note: The use of the term license server (lower case letters) is 
applicable to the option files as described in this section. For the purposes of the 
step-by-step instructions it is not used to refer to the type of network installation 
that runs the licensing software.

Sometimes it is convenient to install Thermo-Calc network clients without providing user input 
after the installation is initiated (an unattended network client installation). This is available for 
Windows and Linux operating systems.

Make sure you know the name or IP number of the computer where the licensing 
software and the license file are to be installed.

Step 1. Create an Option File in a Text Editor to Enter the Options

The following is an example of an option file for a custom network client installation, where 
<name/IP number> is the name or IP number of the computer where the license file is installed:

installation_mode=custom

setup_type=client

enable-components=thermo,databases,tq,tcapi,toolbox,tcpython

icons=1

license_server=<name/IP number>

Below is a shorter example, specifying that a full Thermo-Calc network client should be 
installed:

installation_mode=full_client

license_server=<name/IP number>

Step 2. Go to the Directory Where the Installation File is Saved 

Thermo-Calc can only be installed in unattended mode from the command line 
prompt.

Start the installation in unattended mode using the option file created with this command:
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 l For Windows: <installationfile>.exe --mode unattended --optionfile 
<path\optionfile> 

 l For Linux:  <installationfile>.run --mode unattended --optionfile 
<path/optionfile>

To see other options when you start the Thermo-Calc installation program from the command 
line prompt, run this command:

 l For Windows: <installationfile>.exe –-help

 l For Linux: <installationfile>.run –-help
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Request License Files
In this section:

Request a License File from Thermo-Calc Software 66

Getting License Information Using Thermo-Calc 67

Requesting the License File for Windows or Linux 68

Requesting the License File for macOS 70
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Request a License File from Thermo-Calc Software
The following explains how to retrieve the necessary diagnostic and network adaptor 
information about your computer and then send an email to Thermo-Calc Software to get your 
license file(s) containing the license key(s). 

To set up the correct licensing: 

 1. Make a note of your company or organization’s site number. You can find the site 
number on an invoice or any correspondence from Thermo-Calc Software.

 2. Retrieve your computer diagnostic and network adapter information.

 3. Email Thermo-Calc Software with this information.

 4. A Thermo-Calc Software representative emails you the license file. Save the license file 
lservrc (there is no file suffix) to a location where you can easily access it later.

 Thermo-Calc Support Center on our website

https://thermocalc.com/support/
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Getting License Information Using Thermo-Calc
If you have already installed Thermo-Calc, you can view the license information in the GUI. 
Select Help → Show License Info. 

In Console Mode you can run the SYS module command DISPLAY_LICENSE_INFO.

 1. Open Thermo-Calc.

 2. Click Switch to Console Mode. 

 3. At the SYS: prompt, enter DISPLAY_LICENSE_INFO.You can output the information to a 
FILE or to the SCREEN.

 4. For both options, the information is displayed on screen. Copy the section containing 
the Ethernet and IP address. You can save it to a text file or paste it directly into an 
email. If you choose FILE as the output, then you can attach the file to an email. 
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Requesting the License File for Windows or Linux

Upgrades to a new version of Thermo-Calc: Skip this section if you are upgrading 
to a new version of Thermo-Calc and (and you have a maintenance plan). Your 
license is sent to you in an email from Thermo-Calc Software AB. Save it to your 
computer to use during software installation.

 1. To access the computer information you need to provide to get a license, start 
Thermo-Calc and select Help → Show License Info. 

 2. Copy the information from the License Information window. A lot of information may 
be shown below the initial screen, so make sure you scroll down to the end when you 
select and copy the window's contents. (Alternatively, you can copy the same 
information from the console by using the SYS module command DISPLAY_LICENSE_
INFO.)

 3. Send an email to support@thermocalc.com. Make sure to include the following in the 
subject line:

License diagnostic information from <Name> where Name is replaced with your name, 
the organization name and the Site Number. You can find the five-digit site number on 
an invoice or any correspondence from Thermo-Calc Software. 

mailto:support@thermocalc.com?subject=License diagnostic information from <Name>
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 4. A representative from Thermo-Calc Software replies to the email and attaches your 
license file(s).

 5. Save the license file(s) to your computer or network.
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Requesting the License File for macOS

Upgrades to a new version of Thermo-Calc: Skip this section if you are upgrading 
to a new version of Thermo-Calc and (and you have a maintenance plan). Your 
license is sent to you in an email from Thermo-Calc Software AB. Save it to your 
computer to use during software installation.

 1. From the Apple main menu, select System Preferences.

 2. Click Network.

 3. In the left column select Ethernet or Built-in Ethernet (do not select a WiFi connection 
as a local static MAC address is required).

 4. Click Advanced → Hardware. The Network window shows you the MAC Address. For 
example, the MAC address (the host ID) might be 3c:07:54:28:5f:72.

 5. Send an email to support@thermocalc.com and copy and paste the MAC address into 
the body of the email. Make sure to include the following in the subject line:

License diagnostic information from <Name> where Name is replaced with your name, 
the organisation name and the Site Number. You can find the five-digit site number on 
an invoice or any correspondence from Thermo-Calc Software.  

mailto:support@thermocalc.com
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 6. A representative from Thermo-Calc Software replies to the email address provided and 
attaches your license file or files. 

 7. Save your license file to your computer or network.
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Quick Install Guides
In this section:

Windows® Standalone Quick Install Guide 73

macOS® Standalone Quick Install Guide 77
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Windows® Standalone Quick Install Guide
This quick guide helps you do a full  standalone installation. A standalone installation is used 
with the Single-User Node-Locked License (SUNLL), where the software and the license file are 
together on one computer. 

This guide is applicable to:

 l Windows operating systems

 l Full Standalone installation (SUNLL) 

 l Upgrading to a new standalone version of Thermo-Calc (maintenance plan only)

Other Installations

For instructions about other operating systems, network installations, or installing 
an SDK (e.g. TC-Python or TC-Toolbox for MATLAB®) search the Thermo-Calc 
Installation Guide, which is also available on our website. You can also review the 
Licensing Options included on our website. 

Request a License File

Upgrades to a new version of Thermo-Calc: Skip this section if you are upgrading 
to a new version of Thermo-Calc and (and you have a maintenance plan). Your 
license is sent to you in an email from Thermo-Calc Software AB. Save it to your 
computer to use during software installation.

https://thermocalc.com/content/uploads/Documentation/Current_Static/thermo-calc-installation-guides.pdf
https://thermocalc.com/licensing-options/
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 1. To access the computer information you need to provide to get a license, start 
Thermo-Calc and select Help → Show License Info. 

 2. Copy the information from the License Information window. A lot of information may 
be shown below the initial screen, so make sure you scroll down to the end when you 
select and copy the window's contents. (Alternatively, you can copy the same 
information from the console by using the SYS module command DISPLAY_LICENSE_
INFO.)

 3. Send an email to support@thermocalc.com. Make sure to include the following in the 
subject line:

License diagnostic information from <Name> where Name is replaced with your name, 
the organization name and the Site Number. You can find the five-digit site number on 
an invoice or any correspondence from Thermo-Calc Software. 

 4. A representative from Thermo-Calc Software replies to the email and attaches your 
license file(s).

 5. Save the license file(s) to your computer or network.

mailto:support@thermocalc.com?subject=License diagnostic information from <Name>
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Install the Software

Download and Run your Thermo-Calc Installation Software

Administrative rights are required to complete this installation. 

 1. For web links sent in an email from Thermo-Calc Software, go to the URL and log in with 
the information provided. Then navigate to the Windows folder and click the link to 
download the software.

 2. Go to the folder where you downloaded the software. Right-click the .exe file and 
choose Run as administrator to launch the Setup program. 

 3. On the Setup-Thermo-Calc window click Next. 

 4. On the License Agreement window click to accept the license agreement. Click Next. 

Select the Installation Mode 

 1. In the Select Installation Mode window click Full Standalone: Install all features. 

TC-Python is installed when the Full Standalone or Full Network Client 
option is chosen, but there are additional steps required as described 
separately for this SDK. 

 2. For a Full Standalone installation, in the Choose a license file field either enter the file 

path or click the file button  to navigate to where you saved the license file emailed 
to you from Thermo-Calc Software.
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The license file is called lservrc. Click Next. To prevent errors, leave this 
field blank if you did not get a license file yet. 

TC-Python is installed for all users even if you do not have a license. The 
Install TC-Python window  is a reminder that additional installation 
procedures are required after Thermo-Calc is installed. See the TC-Python 
Installation Guide.  

 3. In the Ready to Install window click Next. Click Finish and start using Thermo-Calc. 
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macOS® Standalone Quick Install Guide
This quick guide helps you do a full  standalone installation. A standalone installation is used 
with the Single-User Node-Locked License (SUNLL), where the software and the license file are 
together on one computer. 

This guide is applicable to:         

 l macOS 

 l Full Standalone installation (SUNLL) 

 l Upgrading to a new standalone version of Thermo-Calc (maintenance plan only)

Other Installations

For instructions about other operating systems, network installations, or installing 
an SDK (e.g. TC-Python or TC-Toolbox for MATLAB®) search the Thermo-Calc 
Installation Guide, which is also available on our website. You can also review the 
Licensing Options included on our website. 

Request a License File

Upgrades to a new version of Thermo-Calc: Skip this section if you are upgrading 
to a new version of Thermo-Calc and (and you have a maintenance plan). Your 
license is sent to you in an email from Thermo-Calc Software AB. Save it to your 
computer to use during software installation.

 1. From the Apple main menu, select System Preferences.

 2. Click Network.

 3. In the left column select Ethernet or Built-in Ethernet (do not select a WiFi connection 
as a local static MAC address is required).

 4. Click Advanced → Hardware. The Network window shows you the MAC Address. For 
example, the MAC address (the host ID) might be 3c:07:54:28:5f:72.

https://thermocalc.com/content/uploads/Documentation/Current_Static/thermo-calc-installation-guides.pdf
https://thermocalc.com/licensing-options/
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 5. Send an email to support@thermocalc.com and copy and paste the MAC address into 
the body of the email. Make sure to include the following in the subject line:

License diagnostic information from <Name> where Name is replaced with your name, 
the organisation name and the Site Number. You can find the five-digit site number on 
an invoice or any correspondence from Thermo-Calc Software.  

 6. A representative from Thermo-Calc Software replies to the email address provided and 
attaches your license file or files. 

 7. Save your license file to your computer or network.

Install the Software

Download and Install XQuartz

The XQuartz open-source X Windows system is required to run Thermo-Calc on macOS X. 

 1. In a web browser go to https://www.macupdate.com or to download it directly from 
XQuartz, http://xquartz.macosforge.org/landing/.

 2. In the Search Mac Apps field, enter XQuartz.

 3. Click the XQuartz search result. For example, based on the recent version, the name is 
XQuartz-2.7.11.dmg.

mailto:support@thermocalc.com
https://www.macupdate.com/
http://xquartz.macosforge.org/landing/
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 4. Click Download. 

 5. Double-click the XQuartz.pkg file. Follow the instructions.

 6. Click OK when the message about logging out displays and click Close when the installation 
is successful.

Download and Run your Thermo-Calc Installation Software

Administrative rights are required to complete this installation. 

 1. For web links sent in an email from Thermo-Calc Software, go to the URL and log in with 
the information provided. Then navigate to the Mac folder and click the link to 
download the software.

 2. Double-click the downloaded file to launch the installation.

For macOS and when you first run the installer, you may see a message 
that Thermo-Calc-osx-<version> can't be opened because Apple cannot 
check it for malicious software. If this happens, select Show in Finder. 
Then, in the opened Finder window right-click the downloaded file 
Thermo-Calc-osx-<version> and select Open.

 3. On the Setup-Thermo-Calc window click Next. 

 4. On the License Agreement window click to accept the license agreement. Click Next. 

Select the Installation Mode

 1. In the Select Installation Mode window click Full Standalone: Install all features. 

TC-Python is installed when the Full Standalone or Full Network Client 
option is chosen, but there are additional steps required as described 
separately for this SDK. 



Quick Install Guides

Other Installations ǀ 80 of 150

 2. For a Full Standalone installation, in the Choose a license file field either enter the file 

path or click the file button  to navigate to where you saved the license file emailed 
to you from Thermo-Calc Software.

The license file is called lservrc. Click Next. To prevent errors, leave this 
field blank if you did not get a license file yet. 

TC-Python is installed for all users even if you do not have a license. The 
Install TC-Python window  is a reminder that additional installation 
procedures are required after Thermo-Calc is installed. See the TC-Python 
Installation Guide.  

 3. In the Ready to Install window click Next. Click Finish and start using Thermo-Calc. 

macOS installations and if you have previous Thermo-Calc installations: When you 
launch Thermo-Calc with the new or updated version, the splash screen hides the 
Import User Settings dialog box. In order to proceed you need to click the splash 
screen and then click Yes or No in the dialog box. 
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TC-Python Installation Guide
In this section:

About the TC-Python Documentation 82

Which TC-Python Installation Should I Choose? 84

Installing TC-Python with a Bundled Python-interpreter 85

Installing TC-Python Into a Python-interpreter of Your Choice 89

Installation Default Directory: TC-Python 93

macOS: Setting Environment Variables 94

Fixing Potential Issues with the Environment 95

Updating to a Newer Version 96

TC-Python Diagnostic Script 97
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About the TC-Python Documentation

The TC-Python help is available on the Thermo-Calc website where you can also 
access additional resources. You can alternatively access the locally installed 
documentation from the Help menu in Thermo-Calc. 

Opening the  Locally Installed Documentation

 1. In Thermo-Calc from the menu, select Help → Manuals Folder. 

You can also navigate to the Manuals folder outside of Thermo-Calc and 
based on your operating system installation location.

 2. In the window that opens, double-click to open the TC-Python folder. 

https://www2.thermocalc.com/docs/tc-python/latest-version/html/
https://thermocalc.com/products/software-development-kits/tc-python/
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 3. Double-click the Index HTML file (or any of the HTML files).

 4. The API reference documentation opens as a searchable HTML file in your local browser. 
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Which TC-Python Installation Should I Choose?

A license is required to run TC-Python. Also remember to review the System 
Requirements page on our website.

There are these options to install TC-Python.

See the Videos about TC-Python page for additional learning resources. 

Install with the Bundled Python-interpreter

This is a straightforward installation where TC-Python is preinstalled together with some 
popular Python packages. 

This is the recommended option for new users to TC-Python who may only want to run the 
examples. The available preinstalled packages (e.g. numpy, scipy, scikit-learn, and 
matplotlib) can also be sufficient for many advanced users. 

"Installing TC-Python with a Bundled Python-interpreter" on the next page.

Install with a Python-interpreter of Your Choice

This installation requires additional steps and is the recommended option for more advanced 
use and has full flexibility. 

"Installing TC-Python Into a Python-interpreter of Your Choice" on page 89.

https://thermocalc.com/system-requirements/
https://thermocalc.com/system-requirements/
https://thermocalc.com/support/video-tutorials/tc-python/


TC-Python Installation Guide

Installing TC-Python with a Bundled Python-interpreter ǀ 85 of 150

Installing TC-Python with a Bundled Python-
interpreter
TC-Python can be installed using a Python-interpreter that is bundled to Thermo-Calc. This 
interpreter has TC-Python preinstalled together with some popular Python packages. This is the 
recommended option for new users to TC-Python who may only want to run the examples. The 
available preinstalled packages (e.g. numpy, scipy, scikit-learn, and matplotlib) can also be 
sufficient for many advanced users. 

The bundled interpreter package is also used to run the Property Models in 
Thermo-Calc. Do not make changes to interpreter packages or this can stop 
Thermo-Calc from working correctly. To fix issues caused by changes to an 
interpreter, completely uninstall Thermo-Calc and start over, either with the 
bundled interpreter package or using interpreters of your choice. 

If you are planning to do more advanced calculations that require other external 
packages then you may want to follow these instructions instead: "Installing 
TC-Python Into a Python-interpreter of Your Choice" on page 89

Limitations

The following examples cannot be run with the bundled Python-interpreter as 
additional packages are required: pyex_M_01_Input_from_file.py (pandas) and 
pyex_M_02_Output_to_file.py (pandas, lxml, h5py).

The bundled Python 3.7.2 interpreter contains the following major packages.

If you have recommendations for additional packages to include (see below), send 
an email to Thermo-Calc Support.

mailto:support@thermocalc.com?subject=Suggestion for new TC-Python packages with the bundled installation
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Package Version

matplotlib 3.3.2

numpy 1.19.2

scikit-learn 0.23.2

scipy 1.5.2

TC-Python 2023a

Step 1. Install an IDE (Integrated Development Environment)

Any editor can be used to write the Python code, but an IDE is recommended, e.g. PyCharm. 
These instructions are based on the use of PyCharm.

Use of an IDE gives you access to code completion, which  helps when you use the API as it gives 
you the available methods on the objects you are working with.

 1. Navigate to the PyCharm website: https://www.jetbrains.com/pycharm/download. 

 2. Click to choose your OS and then click Download. You can use the Community version 
of Pycharm. 

 3. Follow the instructions. It is recommended you keep all the defaults.

For Mac installations, you also need to set some environment variables as 
described below in "macOS: Setting Environment Variables" on page 94.

Step 2. Configure PyCharm to Use the Bundled Python-interpreter

Open PyCharm and configure the interpreter:

 1. Go the menu File→Settings.

 2. Navigate in the tree to Project: YourProjectName and choose Project Interpreter.

 3. Click on the settings symbol close to the Project Interpreter dropdown menu and 
choose Add.

https://www.jetbrains.com/pycharm/download
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 4. Select System Interpreter and add the bundled Thermo-Calc Python 3 interpreter, 
which is located in a folder based on the operating system: 

Operating 
system

Path to the bundled Python-interpreter

Windows C:\Program Files\Thermo-Calc\2023a\python\python.exe

Linux /home/UserName/Thermo-Calc/2023a/python/bin/python3

macOS /Applications/Thermo-Calc-2023a.app/Contents/Resources/python/bin/python3

 5. Select the interpreter and confirm.

Step 3. Run a TC-Python Example

It is recommended that you open one or more of the included examples to both check that the 
installation has worked and to start familiarizing yourself with the code.

Open the TC-Python Project in PyCharm

When you first open the TC-Python project and examples, it can take a few 
moments for the Pycharm IDE to index before some of the options are available.

 1. Open  PyCharm and then choose File  → Open. The first time you open the project you 
will need to navigate to the path of the TC-Python installation based on your operating 
system.

 2. Click the Examples folder and then click OK.

 3. From any subfolder:
 l Double-click to open an example file to examine the code. 

 l Right-click an example and choose Run.
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If you are not following the recommended approach and create a new project 
(File→New Project…), you need to consider that by default the options to choose 
the interpreter are hidden within the Create Project window. For this, click Project 
Interpreter: New Virtual Environment and in most cases choose your System 
Interpreter containing the Python bundled to Thermo-Calc instead of the default 
New Virtual Environment.



TC-Python Installation Guide

Installing TC-Python Into a Python-interpreter of Your Choice ǀ 89 of 150

Installing TC-Python Into a Python-interpreter of Your 
Choice
TC-Python can be installed using a Python-interpreter of your choice. This is the recommended 
option for any more advanced usage and provides full flexibility. 

If you are new to TC-Python and want to mainly run the examples, then it is 
recommended you install the bundled Python-interpreter.  The available 
preinstalled packages (e.g. numpy, scipy, scikit-learn, and matplotlib) can also be 
sufficient for many advanced users. See "Installing TC-Python with a Bundled 
Python-interpreter" on page 85.

Step 1. Install a Python Distribution

If you already have a Python distribution installation, version 3.5 or higher, skip 
this step.

These instructions are based on using the Anaconda platform for the Python distribution. Install 
version 3.5 or higher to be able to work with TC-Python, although it is recommended that you 
use the most recent version. 

Install Anaconda

 1. Navigate to the Anaconda website: https://www.anaconda.com/download/. 

 2. Click to choose your OS (operating system) and then click Download. Follow the 
instructions. It is recommended you keep all the defaults.

Step 2. Install Thermo-Calc and the TC-Python SDK

 1. Install Thermo-Calc. 

 2. When the installation is complete, open the TC-Python folder that includes the *.whl file 
needed for the next step. There is also an Examples folder with Python files you can use 
in the IDE to understand and work with TC-Python. 

https://www.anaconda.com/download/
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Operating 
system

Path to the TC-Python folder

Windows C:\Users\UserName\Documents\Thermo-Calc\2023a\SDK\TC-Python

Linux /home/UserName/Thermo-Calc/2023a/SDK/TC-Python

macOS /Users/Shared/Thermo-Calc/2023a/SDK/TC-Python

Step 3. Install TC-Python

"Updating to a Newer Version" on page 96

On Windows, it is recommended you use the Anaconda distribution prompt (i.e. Anaconda), 
especially if you have other Python installations. 

Do not use Virtual Environments unless you have a good reason to do so. Also see 
"Fixing Potential Issues with the Environment" on page 95.

 1. Open the command line. For example, in Anaconda on a Windows OS, go to Start  → 
Anaconda  → Anaconda Prompt. 

 2. At the command line, enter the following. Make sure there are no spaces at the end of 
the string or in the folder name or it will not run: 

pip install <path to the TC-Python folder>/TC_Python-<version>-
py3-none-any.whl
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On Linux, and depending on the interpreter, pip3 is typically used.

 3. Press <Enter>. When the process is completed, there is a confirmation that TC-Python is 
installed.

If your computer is located behind a proxy-server, the default pip-
command will fail with a network connection error. In that case you need 
to install the dependency py4j in a special configuration:

pip install -proxy user:password@proxy_ip:port py4j

Go to the TC-Python Help Troubleshooting section for detailed information. 
This can be found on our website or from the installed documentation 
where you can search for "pip install fails".

Step 4. Install an IDE (Integrated Development Environment)

Any editor can be used to write the Python code, but an IDE is recommended, e.g. PyCharm. 
These instructions are based on the use of PyCharm.

Use of an IDE gives you access to code completion, which  helps when you use the API as it gives 
you the available methods on the objects you are working with.

 1. Navigate to the PyCharm website: https://www.jetbrains.com/pycharm/download. 

 2. Click to choose your OS and then click Download. You can use the Community version 
of Pycharm. 

 3. Follow the instructions. It is recommended you keep all the defaults.

For Mac installations, you also need to set some environment variables as 
described below in "macOS: Setting Environment Variables" on page 94.

Step 5. Open the IDE and Run a TC-Python Example

After you complete all the software installations and set up the pip install path, you are ready 
to open the IDE to start working with TC-Python.

https://www2.thermocalc.com/docs/tc-python/latest-version/html/
https://www.jetbrains.com/pycharm/download
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It is recommended that you open one or more of the included examples to both check that the 
installation has worked and to start familiarizing yourself with the code.

Open the TC-Python Project in PyCharm

When you first open the TC-Python project and examples, it can take a few 
moments for the Pycharm IDE to index before some of the options are available.

 1. Open  PyCharm and then choose File  → Open. The first time you open the project you 
will need to navigate to the path of the TC-Python installation based on your operating 
system.

 2. Click the Examples folder and then click OK.

 3. From any subfolder:
 l Double-click to open an example file to examine the code. 

 l Right-click an example and choose Run.
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Installation Default Directory: TC-Python
These are the default paths to the TC-Python folder based on your operating system.

Operating 
system

Path to the TC-Python folder

Windows C:\Users\UserName\Documents\Thermo-Calc\2023a\SDK\TC-Python

Linux /home/UserName/Thermo-Calc/2023a/SDK/TC-Python

macOS /Users/Shared/Thermo-Calc/2023a/SDK/TC-Python

For a bundled Python-interpreter installation, these are the paths to this location based on your 
operating system. 

Operating 
system

Path to the bundled Python-interpreter

Windows C:\Program Files\Thermo-Calc\2023a\python\python.exe

Linux /home/UserName/Thermo-Calc/2023a/python/bin/python3

macOS /Applications/Thermo-Calc-2023a.app/Contents/Resources/python/bin/python3
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macOS: Setting Environment Variables
In order to use TC-Python on Mac you need to set some environment variables.

TC23A_HOME=/Applications/Thermo-Calc-2023a.app/Contents/Resources

If you use a license server:

LSHOST=<name-of-the-license-server>

If you have a node-locked license:

LSHOST= NO-NET

LSERVRC=/Users/Shared/Thermo-Calc/lservrc

In PyCharm, you can add environment variables in the configurations. 

Select Run  → Edit Configurations to open the Run/Debug Configurations window. Enter the 
environment variable(s) by clicking the button to the right of the Environment Variables text 
field. Now the environment variables(s) will be set for each new configuration by default. The 
same way for configuring the environment variables can be used on other operating systems as 
if necessary.
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Fixing Potential Issues with the Environment
In most cases you should run TC-Python within your global Python 3 interpreter and not use 
Virtual Environments unless you have a good reason to do so. 

If there are problems with the interpreter settings, for example, a common problem when you 
first use TC-Python is the message No module named tc_python, which you can resolve in the 
Settings window as follows:

 1. Go the menu File  → Settings.

 2. Navigate in the tree to <Project.YourProjectName> and choose Project Interpreter.

 3. Click on the settings symbol close to the Project Interpreter drop-down menu and 
choose Add.

 4. Now choose System Interpreter and add your existing Python 3 interpreter.

 5. Select your added interpreter and confirm.

If you are not following the recommended approach and create a new project 
(File→New Project…), you need to consider that by default the options to choose 
the interpreter are hidden within the Create Project window. For this, click Project 
Interpreter: New Virtual Environment and in most cases choose your System 
Interpreter containing the Python bundled to Thermo-Calc instead of the default 
New Virtual Environment.

If you really need to use a Virtual Environment, it is recommended you review the 
hints provided in the Best Practices section in the full TC-Python HTML help or 
PDF.
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Updating to a Newer Version

If you are using the bundled Python-interpreter automatically installed with 
Thermo-Calc, these steps are not required.

These steps are required if you have previously followed the instructions in 
"Installing TC-Python Into a Python-interpreter of Your Choice" on page 89.  

When updating to a newer version of Thermo-Calc, you always need to also install the latest 
version of TC-Python. It is not sufficient to run the installer of Thermo-Calc (except for bundled 
versions of the Python interpreter). 

pip install <path to the TC-Python folder>/TC_Python-<version>-py3-
none-any.whl

In case of problems you may wish to uninstall the previous version of TC-Python in advance:

pip uninstall TC-Python

pip install <path to the TC-Python folder>/TC_Python-<version>-py3-
none-any.whl

However, this should not normally be required. 

On Linux typically pip3 is used.

You can check the currently installed version of TC-Python by running:

pip show TC-Python
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TC-Python Diagnostic Script
A diagnostic script is available to help you if you have problems running TC-Python.

It is important to run the diagnostic script EXACTLY the same way as you run your 
TC-Python script (in the same IDE, same project, same Python environment, same 
Jupyter notebook, etc).

The script automatically prints useful suggestions that, in many cases, will help you to fix the 
problem yourself. If you are unable to solve the problem, contact us for support. You can find 
the script in these locations:

 l Miscellaneous example (diagnostics.py) 

 l In the Troubleshooting section of the TC-Python API Reference Documentation. Also 
refer to the Best Practices in the same guide to see if there are any other solutions or 
tips.

 l On our website. 

https://www2.thermocalc.com/downloads/support/diagnostics-py/
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TC-Toolbox for MATLAB® Installation Guide
In this section:
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About TC-Toolbox for MATLAB®

TC-Toolbox for MATLAB® (TC-Toolbox) provides an interface to the commonly used MATLAB® 
software for scientific and engineering computing. This software development kit (SDK) is ideal 
for fast realization of ideas and visualization of results during research and development 
activities. The TC-Toolbox API includes calculation types available in Thermo-Calc such as single 
point equilibrium, property (step) and phase (map) diagrams, Scheil solidification simulations, 
as well as all the general Thermo-Calc Property Models (e.g. yield strength, spinodal, driving 
force, etc.). 

With the addition of licenses for the applicable software and databases, you can further 
maximize your integration with MATLAB® to include the capabilities of the Steel Model Library 
Property Models (e.g. bainite, pearlite, etc.), as well as access the range of functionality 
included with the Diffusion Module (DICTRA) and the Precipitation Module (TC-PRISMA). 
Generally, all the functionality available in Graphical Mode or via the TC-Python SDK is 
available.

TC-Toolbox for MATLAB® is available on Windows platforms.

A license is required to run TC-Toolbox for MATLAB® and MATLAB® must also be 
installed on your computer prior to the TC-Toolbox installation. Also remember to 
review the System Requirements page on our website.

https://thermocalc.com/system-requirements/
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TC-Toolbox Documentation
There are various locations and formats of the documentation you need related to this SDK. 

The TC-Toolbox for MATLAB® API Reference Documentation is available from these 
general locations (1) within the MATLAB® environment—both as help and as part 
of the tab completion (2) directly on the Thermo-Calc website, and (3) locally in 
the Thermo-Calc installation (Help>Manuals Folder). 

API Reference Documentation 

The TC-Toolbox for MATLAB® API Reference Documentation is available either as interactive 
help (in HTML format or when in MATLAB® using tab completion or accessed via different 
menus or key combinations) or as a standalone PDF. 

There are these ways to access the content:

 l Directly in MATLAB® via the Help menu then under Supplemental Software click 
TC-Toolbox. Help is also available when writing code and using the tab completion 
feature and/or pressing different key combinations as described in the Best Practices 
section of the help. 

 l From the website: HTML Help or PDF

 l Locally in a Thermo-Calc installation: 
 l HTML: Help > Manuals Folder > TC-Toolbox_MATLAB, then click any HTML file.

 l PDF: Help > Manuals Folder > Software Development Kits (SDKs), then double-
click to open the TC-Toolbox for MATLAB® API Programmer Guide. This is a copy 
of the HTML API reference documentation.

Installation Instructions

The installation instructions  are only included in the Thermo-Calc help (press F1), and in the 
PDF version of the main installation guide found, for example:

https://www2.thermocalc.com/docs/tc-toolbox/latest-version/html/
https://www2.thermocalc.com/docs/tc-toolbox/latest-version/html/
https://thermocalc.com/content/uploads/Documentation/Current_Static/tc-toolbox-for-matlab-programmer-guide.pdf


TC-Toolbox for MATLAB® Installation Guide

TC-Toolbox Documentation ǀ 101 of 150

 l On our website as part of the full Thermo-Calc Installation Guide.

 l Once Thermo-Calc is installed:
 l Locally in a Thermo-Calc installation: Help > Manuals Folder >Installation 

Guides.

 l Press F1 in Thermo-Calc to search the help.

Thermo-Calc Help (Limited)

For TC-Toolbox, there is limited content included in the Thermo-Calc help (press F1 when in 
Thermo-Calc) because it is replaced by the TC-Toolbox for MATLAB® API Reference 
Documentation.  The exception is installation instructions to describe how to install the SDK.

https://thermocalc.com/content/uploads/Documentation/Current_Static/thermo-calc-installation-guides.pdf
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Installation Default Directory: TC-Toolbox and the 
Examples
The software component and the examples are installed as described below. 

This is the default path to the installation folder for the TC-Toolbox component on Windows 
operating systems. Be aware that the initial installation files and examples are placed in 
Public\Documents, then after opening Thermo-Calc for the first time, these are copied to the 
Documents folder for each user. The documentation is installed elsewhere and as described in 
"TC-Toolbox Documentation" on page 100.

There are included examples with all TC-Toolbox installations. These are the same as the 
examples included with TC-Python although with a different suffix (matex) and prefix (*.m) in 
the file name. You can read summaries about the examples as described for TC-Python in the 
online help.

Path to the TC-Toolbox folder

Both the installation files AND the examples are installed in the following folders. 

The default Windows folders where the TC-Toolbox examples are installed starts with the original installation placing these 
under Public Documents for ALL USERS. 

For a local user, and after Thermo-Calc is opened for the first time, these files are copied to the user’s Documents folder 
where this local copy is associated to the user login. The Public Documents folder always contains the original set of 
contents as per the installation.

C:\Users\Public\Public Documents\Thermo-Calc\<version>\SDK\TC-Toolbox-MATLAB

After installing Thermo-Calc, and when you first open the program, the set of folders containing the examples is copied 
from the source Public\Documents location into a user Documents folder:

C:\Users\<user>\Documents\Thermo-Calc\<version>\SDK\TC-Toolbox-MATLAB\Examples

It is recommended that you work with the files that are copied to the user folder.
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Installing TC-Toolbox
There are automatic or manual installation instructions for TC-Toolbox for MATLAB®.

Automatic Installation of TC-Toolbox

When the following conditions are met, Thermo-Calc automatically installs the TC-Toolbox for 
MATLAB® component on your computer.

 1. MATLAB® is already installed.

 2. There is only one Windows user on the computer where TC-Toolbox is being installed.

Administrator privileges are needed when you start the Thermo-Calc 
installer.

Then  follow the regular installation instructions for Thermo-Calc, choosing whether you use a 
Standalone or Network installation. If required also see "Testing a TC-Toolbox Installation" on 
page 109.

A reminder regarding the license. Although you do not need to have a license file 
during the installation process (it can be added after the fact), you do need to have 
purchased a license for TC-Toolbox for MATLAB® to run the program within 
MATLAB®.

Manual Installation of TC-Toolbox 

The installation is not automatic if:

 l There are multiple Windows users on the same machine, or

 l The installer cannot find the directory path to the MATLAB installation.

Multiple Windows Users on Same Machine

If there are multiple windows users on the same machine, then the following manual steps are 
done at the end of the automatic installation. 



TC-Toolbox for MATLAB® Installation Guide

Installing TC-Toolbox ǀ 104 of 150

 1. A message at the end of the Thermo-Calc installation process displays with instructions. 

 2. An Explorer window automatically opens to the C:\Users\Public\Documents\Thermo-
Calc\2023a\SDK\TC-Toolbox-MATLAB folder.

 3. Double-click the InstallTCToolboxMATLAB.cmd file to finalize the process. This briefly 
launches MATLAB® and installs TC-Toolbox. If required see "Testing a TC-Toolbox 
Installation" on page 109.

Installer Cannot Find the MATLAB® Installation Directory

If the Thermo-Calc installer cannot find the MATLAB® installation directory, 

 1. Start the version of MATLAB® that you want to install TC-Toolbox in.

 2. Open and run the MATLAB® script included with your installation of Thermo-Calc. 

For example on Windows, C:\Users\<username>\Documents\Thermo-
Calc\2023a\SDK\TC-Toolbox-MATLAB\setupTCToolbox.m

You can also follow the instructions for "Installing TC-Toolbox with the Custom 
Option" on the next page.



TC-Toolbox for MATLAB® Installation Guide

Installing TC-Toolbox with the Custom Option ǀ 105 of 150

Installing TC-Toolbox with the Custom Option

MATLAB® must be installed before you install TC-Toolbox.

As described in "Installing TC-Toolbox" on page 103, if MATLAB® is already installed, then 
Thermo-Calc  automatically installs the files you need either using the Full Standalone or Full 
Network Client installation where you install all features. Otherwise you need to use the 
Custom installation.

The following generally describes the Custom option for either a Standalone or Network 
installation. Use the Custom option if MATLAB® is installed but the Thermo-Calc installer is not 
finding the directory path so you need to enter the path manually.

Some steps are described in more detail in other parts of this guide. 

Step 1. Request your License File from Thermo-Calc Software

A reminder regarding the license. Although you do not need to have a license file 
during the installation process (it can be added after the fact), you do need to have 
purchased a license for TC-Toolbox for MATLAB® to run the program within 
MATLAB®.

Step 2. Download your Thermo-Calc Installation Software 

Step 3. Install MATLAB®

Step 4. Run the Thermo-Calc Installation File as an Administrator

 1. Locate the Thermo-Calc installation file on your computer. Right-click the .exe file and 
choose Run as administrator to launch the Setup program. 

 2. Accept the License Agreement and click Next.



TC-Toolbox for MATLAB® Installation Guide

Installing TC-Toolbox with the Custom Option ǀ 106 of 150

Step 5. Select the Custom Installation Type

 1. In the Select Installation Mode window click Custom (the option appears greyed out, 
but it is available to select). Click Next.

 2. On the Specify Configuration window the Create Shortcut on Desktop check box is 
selected by default. Click Next.

 3. In the Select Components window, click to select  the TC-Toolbox for MATLAB check 
box. 

Remember, you must have MATLAB® already installed and may need to 
know the file path to the MATLAB® folder. If the TC-Toolbox for MATLAB 
check box is NOT selected, this confirms that the Thermo-Calc installer did 
NOT locate the MATLAB® installation (or it is not installed yet). 
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 4. Click Next.

 5. If you selected the TC-Toolbox for MATLAB check box, the MATLAB directory window 
opens. 

 l If MATLAB® is already installed but the Thermo-Calc installer could not find the 
path, then enter the file path to the MATLAB® installation directory or click the 
file button  to Browse for Folder and navigate to the directory. Click Next.

 l If MATLAB® is NOT installed, click Cancel to exit the Thermo-Calc installer 
program. Once MATLAB® is installed you can return to this process.

Step 6. Set the Thermo-Calc Installation Directory and Choose the 
Setup Type

 1. In the Installation Directory window, either accept the default path or enter a path to 
where you want to install the Thermo-Calc software. Click the file button  to Browse 
for Folder and navigate to another directory. 

 2. In the Choose Setup Type window, click Standalone or Network Client.
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 l For a Standalone installation: In the Choose a license file field enter the path to 
your license file (called lservrc).

 l For a Network installation: Enter the details as required into the Enter the name 
or IP number of the licensing server field. Click Next.  

If the TC-Python check box is also selected to be installed (which it 
is by default), the Install TC-Python window  is a reminder that 
additional installation procedures are required after Thermo-Calc is 
installed. 

Step 7. Install  and Start Using Thermo-Calc as an Add-on in 
MATLAB®

 1. In the Ready to Install window click Next.

If MATLAB® is not installed (and you selected the TC-Toolbox check box) a 
message displays to confirm that TC-Toolbox will not be installed until you 
complete the MATLAB® installation. If MATLAB is installed, click Back to 
confirm that the installation path is correct, otherwise Cancel this Thermo-
Calc installation, install MATLAB and start again. 

 2. Click Finish. 

Step 8. Test the Installation

"Testing a TC-Toolbox Installation" on the next page
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Testing a TC-Toolbox Installation
Generally you can check the installation by first looking in the Home tab to see if the program is 
in the menu. Then proceed to running the diagnostic script or another example. 

To check the installation, in MATLAB®:

 1. From the Add-Ons menu, select Manage Add-Ons. 

If TC-Toolbox is in the list it is likely it installed correctly but it is recommended you run 
the diagnostic script or another example to confirm.

 2. Run the diagnostics script from the folder C:\Users\<user>\Documents\Thermo-
Calc\2023a\SDK\TC-Toolbox-MATLAB\Examples\Miscellaneous or open and run any 
other example to test.

The TC-Toolbox diagnostic script is also available from our website.

https://www2.thermocalc.com/downloads/support/diagnostics-m/
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TC-Toolbox Installation Troubleshooting
Below are some suggestions to help troubleshoot a TC-Toolbox for MATLAB® installation.

Diagnostic Script

A diagnostic script is available to help you if you have problems running TC-Toolbox. 

It is important to run this script EXACTLY the same way as you run your MATLAB® 
script.

The script automatically prints useful suggestions that, in many cases, will help you to fix the 
problem yourself. If you are unable to solve the problem, contact us for support. 

The script is based on the version of Thermo-Calc installed and named tc-toolbox-
diagnostic-script-2023a.m. You can find the script in these locations:

 l As an example (diagnostics.m) located in this folder 
C:\Users\<user>\Documents\Thermo-Calc\2023a\SDK\TC-Toolbox-

MATLAB\Examples\Miscellaneous 

 l In the Troubleshooting section of the TC-Toolbox for MATLAB® API Reference 
Documentation. Also refer to the Best Practices in the same guide to see if there are any 
other solutions or tips.

 l On our website. 

MATLAB® Installation Directory Not Found

For Windows installations of the TC-Toolbox for MATLAB® component, you may get an error 
message or window asking for the MATLAB® installation directory path. 

The most common reason for this is that MATLAB® is not installed. If this is the 
case, exit the Thermo-Calc installation, install MATLAB® and then run the 
Thermo-Calc installation program again.

If MATLAB® is installed and Thermo-Calc just did not find the file path during the installation 
setup process, then enter the path in the field when prompted. 

https://www2.thermocalc.com/downloads/support/diagnostics-m/
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Determining the Licensing Software Version (Network Installs)

Sometimes you may need to know the version of License Manager (Windows) or License Server 
(Linux) software being used. This can be useful while troubleshooting network installations.

 l On Windows open a command prompt and go to the directory where lservnt.exe is 
found. For example:

>C:\Program Files (x86)\Common Files\SafeNet Sentinel\Sentinel RMS 
License Manager\WinNT

Type the command >lservnt.exe –help and the version is displayed.

 l On Linux open a Terminal window and go to the directory where the lserv script is 
saved. For example:

>cd opt/Thermo-Calc/<version>/Licensing-files

Type the command >./lserv –help and the version is displayed.
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Uninstalling TC-Toolbox for MATLAB®

Uninstallation requires that the user is logged in with administrator rights and Thermo-Calc is 
installed for this same user. Then the uninstallation is automatically completed as part of the 
uninstallation of Thermo-Calc.  Otherwise a manual step is required.

To uninstall TC-Toolbox (when not automatically uninstalled):

 1. Start MATLAB®. 

 2. In the Home tab from the Add-Ons menu, select Manage Add-Ons. 

 3. Right-click TC-Toolbox and choose Uninstall.
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Troubleshooting

There are diagnostic scripts available for TC-Python and TC-Toolbox for MATLAB® 
(these are included as examples in the Miscellaneous folder).  These scripts are also 
available on our website.

In this section:

License Errors 114

Determining the Current License File Directory Path 116

Specifying a New Server Name or IP Number 118

Firewalls 119

Client/Server Mismatch 120

macOS Installations: Running the License Initialization Script 122

Linux Installations: Running the License Initialization Script 123

https://thermocalc.com/support/documentation/


Troubleshooting

License Errors ǀ 114 of 150

License Errors

Issue Platform
Installation 
type

Action or link to more information

How do I add or update a 
standalone (SUNLL) license 
on a Windows computer 
where Thermo-Calc is 
already installed?

Windows Standalone
"Determining the Current License File Directory 
Path" on page 116

How do I add or update a 
standalone (SUNLL) license 
on a Linux computer where 
Thermo-Calc is already 
installed?

Linux Standalone
"Determining the Current License File Directory 
Path" on page 116

How do I add or update a 
network license on 
Windows?

Windows Network
"Determining the Current License File Directory 
Path" on page 116

How do I add or update a 
network license on Linux?

Linux Network
"Determining the Current License File Directory 
Path" on page 116

No license file found. Copy a 
valid license file to the 
installation directory after 
completing the installation.

All All

You get this message if the wrong path or no 
license file is found at a path entered during the 
installation process. See "Installation Default 
Directories and the License File " on page 21 and 
"Determining the Current License File Directory 
Path" on page 116

TC-Toolbox for MATLAB® Windows All
"TC-Toolbox Installation Troubleshooting" on 
page 110

Warning Environment 
variable “LSHOST” is not set. 
Software will not function 
properly.

All Network
"Specifying a New Server Name or IP Number" 
on page 118

Problem running post-install 
step. Installation may not 
complete correctly. 

Unable to run post-
installation script, run the 
license initialization script as 
root after the installation.

Linux and 
Mac

Standalone

"macOS Installations: Running the License 
Initialization Script " on page 122or "Linux 
Installations: Running the License Initialization 
Script" on page 123
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Issue Platform
Installation 
type

Action or link to more information

Firewall warnings related to 
license management 
software (License Manager 
and License Server)

Windows and 
Linux

Network "Firewalls" on page 119

Client / Server naming 
mismatches

Windows and 
Linux

Network "Client/Server Mismatch" on page 120

InstallScript engine missing Windows Network 

You are not notified if the InstallScript scripting 
engine is not installed. Install the ISScript.msi file 
and then run the downloaded file from 
Thermo-Calc again as described in "Windows: 
About Installing the License Manager" on 
page 46  
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Determining the Current License File Directory Path
This topic explains how to find out where your license file is installed, either by default or if a 
different directory was chosen for previously installed versions. For new installations, where 
you may not have had a license file when you installed Thermo-Calc, you can also use these 
instructions to determine the correct file path. 

From Thermo-Calc

If you have already installed Thermo-Calc, you can view the path to the license file in the GUI. 
Select Help → Show License Info. 

In Console Mode you can run the SYS module command DISPLAY_LICENSE_INFO.

Windows Standalone Installations

How do I add or update a standalone (SUNLL) license on a Windows computer where 
Thermo-Calc is already installed?

 1. Unpack the .zip file that contains your standalone license and save the LSERVRC file on 
your computer. Find out where to place the new license file by opening a Command 
Prompt Window (cmd.exe) and type in the command line:

>set LSERVRC

 2. Press Enter. The output from the command is the path to the license file (including the 
name of the license file). For example: if the output is

LSERVRC=C:\Users\<user>\Documents\Thermo-Calc\lservrc

then the new license file should be placed in C:\Program 
Files\Thermo-Calc\2023a\

Linux Standalone Installations

How do I add or update a standalone (SUNLL) license on a Linux computer where Thermo-Calc is 
already installed?

Find out where to place the new license file by opening a Terminal window and type in the 
command line:

echo $LSERVRC
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Windows Network Installations

How do I add or update a network license on Windows?

Only the WlAdmin tool can be used to update the network license used by the License 
Manager. See Install the Thermo-Calc Network License Using WIAdmin.

Linux Network Installations

How do I add or update a network license on Linux?

Replace your current license file with the new license file. The license file is located in the same 
directory as the license server.
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Specifying a New Server Name or IP Number
The Thermo-Calc Setup wizard does not warn you if the name or IP number entered to the 
server (with the license management software) is incorrect. 

If the name or IP number is not set at all, or if it is set to an empty string, then when you start 
Thermo-Calc the following message displays: Warning Environment variable “LSHOST” is not 
set. Software will not function properly. 

Windows

This section explains how to specify or change the name or IP number of the server where the 
License Manager is installed and for a consolidated network client installation.

To install a license for an existing Thermo-Calc program, follow these steps:

 1. Close all running Thermo-Calc programs.

 2. Open a command line window. 

 3. Specify the name or IP number of the licensing software server. Type: 

set LSHOST=<name/IP number>

To display the current name or IP number, type:

set LSHOST

macOS

Permanently set the environmental variable LSHOST to specify a new licensing server name or 
IP number. Refer to the file /Applications/Thermo-Calc-2023a.app/Contents/Info.plist. 

In this file, you can manually set the TC23A_HOME variable, which specifies the home directory 
of the Thermo-Calc program. See the Info.plist file for an example.

Linux

You can set or change the name or IP number of the license server at a later time by setting the 
environmental variable “LSHOST” to this name or number.
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Firewalls

Windows

For a Windows License Manager installation you may have to change the system firewall 
settings to allow the License Manager to communicate with the computers running the client 
applications. Go to the Windows Firewall settings window to see if there are any problems. If 
prompted, select Unblock the system firewall for the Sentinel RMS License Manager and click 
Next.

Linux

For a Linux License Server installation you need to open the UDP port 5093 in your firewall. In 
case you have installed SELinux you might also need to disable it by setting SELINUX=permissive 
in the /etc/selinux/config file.
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Client/Server Mismatch
For some network installations there can be a naming mismatch that causes errors. The server 
(where the license management software is installed) gets information from its DNS servers 
that an IP address (aaa.bbb.ccc) belongs to a computer (Computer A). But the client computer 
identifies itself as having a different IP address (aaa.bbb.ccc.eee) for the same computer 
(Computer A).

Even if the IP address of the client computer belongs to a subnet range listed in the license file, 
there is a problem with accessing the license file because the computer name does not match 
the information.

You may need your organisation’s network administrator to assist with this issue.

How to Check

Compare computer names on the client computer and server

 1. On the client computer, start a command prompt cmd.exe and type ipconfig /all. 
Press Enter. A variety of data is displayed on screen. Write down the following 
information for later comparison:

 l Hostname

 l DNS Suffix

 l Current IPv 4 Address

 2. In the command window, type nslookup <client_computer_name>, where client_
computer_name is the actual name of the client. Press Enter. 

This shows what information is saved on the DNS Servers used by the client 
computer. This information should match what is shown in the output from the 
first step.

 3. On the server that holds the license management software, open a command prompt 
and run the command line: nslookup client_computer_name. The output lists the 
information for this server.

Does it match the information given by the command ipconfig /all on the client 
computer? If not try the following.
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Try these options to correct the issue

 1. If the client computer has a dynamic (DHCP) IP address, either change it to a static one 
or make a reservation on the DHCP Server so that the computer always get the same IP 
address. 

 2. Update the records on the DNS Servers used by both the client computer and the server 
computer. 

You can also configure the computer names and IP addresses in the local Hostfile of the client 
and server:

 1. On the client computer, make a backup copy of the file 
C:\Windows\System32\drivers\etc\hosts. 

 2. Open the original in a simple text editor.

 3. Add a new line which contains the IP and name of the server, for example: 
192.168.29.27 license_server.thermocalc.se. 

 4. Save the changes.

 5. On the server, make a backup copy of the file /etc/hosts.

 6. Open the original in a simple text editor. 

 7. Add a new line which contains the IP and name of the client, for example: 192.168.29.47 
Computer_A.thermocalc.se.

 8. Save the changes.

 9. In the host file, there is an example of how the operating system (Windows or Linux) 
wants the line in the hosts file to look like.
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macOS Installations: Running the License Initialization 
Script 
As part of the Standalone installation of Thermo-Calc, the Setup runs a license initialization 
script. If this part of the installation process did not complete properly for a standalone 
installation, you must manually run the license initialization script. You need the administrator 
username and password for these steps.

How to Run the Script

For this script to successfully initialize the license, the license file must be called lservrc and be 
located in the folder: 

/Users/Shared/Thermo-Calc

"Installation Default Directory: macOS" on page 23

 1. Open a terminal window. The Terminal application is in the /Applications/Utilities 
folder.

 2. At the prompt, enter this command:

$ sudo /Applications/Thermo-Calc-
2023a.app/Contents/Resources/license-initialization-macOS-x86_
64.sh

If you are not already logged in as an administrator, you probably cannot run the sudo 
command. If this is the case, then you can use the su command in the terminal window 
to login as an administrator. Contact your local system administrator for help.

 3. Enter the administrator password and press Enter. 

 4. When you restart your computer and run the license initialization script, you are ready 
to start using Thermo-Calc. 

If you did not install a license file during this procedure, you can still start 
Thermo-Calc although you will get the No license file found message. 
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Linux Installations: Running the License Initialization 
Script
As part of a Standalone installation of Thermo-Calc, the Setup runs a license initialization script. 
If you get a warning message during the standalone installation Unable to run post-installation 
script, run the license initialization script as root after the installation, then you need to 
manually run the script as root.

openSUSE Administration (sudo) Users 

Note the following if you are a sudo user (administrator) in openSUSE installing Thermo-Calc 
using this command:

sudo ./linux-installation-x64-6.0.0.17347.run

When this command is used, you will do a text-based installation instead of having a graphical 
interface to guide you. The information  is the same, just without the user interface. 

How to Run the Script

For this script to successfully initialize the license, the license file must be called 
lservrc and be located in the directory where you have installed Thermo-Calc. 

"Installation Default Directory: Linux" on page 24

 1. In the console, go to the Thermo-Calc installation directory. 
 l The license file is put in /home/<user>/Thermo-Calc  if you are installing as a 

non-root user, where <user> is your user name. 

 l If you are installing as root, then this directory is opt/Thermo-Calc/.

 2. Enter this command:

$ sudo sh license-initialization-linux.sh

If you are not able to execute the sudo command because you are not on the sudoers 
list, you must log in as a root user with the command su, and then use sh to run the 
license initialization script. For example, on a 64-bit computer, enter the following:

$ sh license-initialization-linux.sh
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 3. Log out of Thermo-Calc and then log back in to save these changes. 
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Sentinel RMS License 9.7 Tools
These tools relate to Network Client installations of the Sentinel RMS License software.

"Windows: Installing the Sentinel RMS License Manager" on page 48 or "Linux: 
Installing the Sentinel RMS License Server" on page 54

In this section:

GetHostID: Get HostID/Mac Address 126

lsmon: Monitor License Manager Transactions 127

lspool: Maintain Redundant License Manager Pool 128

lsrvdown: Shut Down the License Manager 130

lswhere: Display a List of License Managers 131

WlmAdmin Administrative Tool 132

Sldemo: Show Basic API Functions 136

Wechoid: Get a Computer Locking Code 140
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GetHostID: Get HostID/Mac Address
GetHostID is a tool that retrieves the HostID/Mac address from the computer hosting the 
license server and saves it to a text file.

For Linux the output file is called gethostid.log. For Windows it is called TC_
Hostid.txt.

 l This is related to the "Full Network Client Installations" on page 44 using the Sentinel 
RMS License Manager (Windows) or Server (Linux), version 9.7. 

 l The tool is applicable to Windows and Linux (32-bit and 64-bit) operating systems. See 
"Windows: Installing the Sentinel RMS License Manager" on page 48 or "Linux: Installing 
the Sentinel RMS License Server" on page 54.

Windows

 1. Extract getHostID_win.zip.

 2. Right-click getHostID_win.bat and select Run as Administrator from the menu.

The output is saved in a file: TC_Hostid.txt located in the same folder as getHostID_
win.bat.

Linux 32-bit

 1. Extract gethostid.tar.

 2. Run the command: >./gethostid. 

The output is saved in a file: gethostid.log located in the same directory as gethostid.

Linux 64-bit

 1. Extract gethostid64.tar.

 2. Run the command: >./gethostid64. 

The output is saved in a file: gethostid.log located in the same directory as 
gethostid64.
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lsmon: Monitor License Manager Transactions 
 l This is related to the "Full Network Client Installations" on page 44 using the Sentinel 

RMS License Manager (Windows) or Server (Linux), version 9.7. 

 l The tool is applicable to Windows and Linux (32-bit and 64-bit) operating systems. See 
"Windows: Installing the Sentinel RMS License Manager" on page 48 or "Linux: Installing 
the Sentinel RMS License Server" on page 54.

Platforms

Windows, Linux 32-bit, Linux 64-bit

The tool retrieves information about all features currently licensed by the Sentinel RMS License 
Manager, licenses, and clients.

On UNIX computers, you can use "Poll-interval-in-seconds" to specify that lsmon should keep 
monitoring and reporting usage activity instead of displaying information once and stopping. If 
specified, lsmon waits for that many seconds between re-polls of the License Manager. 

lsmon monitors all licensed applications supported by a License Manager. If the License 
Manager supports licensed applications from multiple vendors, then all licenses for all vendors 
are displayed.

 l On Windows, use lsmon [Server-host] 

 l On Linux 32-bit, use lsmon [Poll-interval_in_seconds] [Server-host]

 l On Linux 64-bit, use lsmon64 [Poll-interval_in_seconds] [Server-host]

Options

 l Poll-interval_in_seconds: Enable periodic update at indicated rate. This option is 
supported on UNIX only).

 l Server-host: The name of the computer on which the License Manager is running. If 
Server-host is omitted, lsmon will attempt to talk to the Sentinel RMS License Manager 
on the computer indicated in the LSHOST environment variable or in the LSHOST (or 
lshost) file. If the variable or the file does not exist, then it will attempt to contact a 
License Manager using the broadcast mechanism. If lsmon fails to find a Sentinel RMS 
License Manager, it will display an error message and exit.



Sentinel RMS License 9.7 Tools

lspool: Maintain Redundant License Manager Pool ǀ 128 of 150

lspool: Maintain Redundant License Manager Pool
 l This is related to the "Full Network Client Installations" on page 44 using the Sentinel 

RMS License Manager (Windows) or Server (Linux), version 9.7. 

 l The tool is applicable to Windows and Linux (32-bit and 64-bit) operating systems. See 
"Windows: Installing the Sentinel RMS License Manager" on page 48 or "Linux: Installing 
the Sentinel RMS License Server" on page 54.

lspool is a redundant License Manager administration utility (command-line) for Windows and 
UNIX. 

Options

 l h Displays a list of lspool usage options.

 l a <license manager> Adds the License Manager to the redundant License Manager pool. 
Specify the hostname or IP address of the License Manager system. Modifies the 
redundant license file.. On Windows, dynamic addition of License Manager in an existing 
redundant pool is not supported.

 l d <license manager> Deletes the License Manager from the redundant License Manager 
pool. Specify the hostname or IP address of the License Manager system. Modifies the 
redundant license file. On Windows, dynamic deletion of License Manager in an existing 
redundant pool is not supported.

 l l Displays the host name of the leader redundant License Manager.

 l p Displays the list of License Managers in the redundant License Manager pool.

 l g < feature> <version> Displays the license token distribution criteria for the specified 
feature/version. If the version is not specified, it must be replaced with empty quotation 
marks: " ".

 l L <event> <OFF|ON> Disables/enables logging for an event. The events you select will 
be logged into the License Manager trace log file (only if error logging is enabled).

lspool - L Options

Events that can be logged using the -L option are given below. The following events are 
temporarily logged (except 1) and need to be set each time the License Manager is restarted.

 l 0 Logs all events.

 l 1 Logs when the License Manager is up. On by default. 2 Logs election of the leader 
License Manager.
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 l 3 Logs the two-way redundant License Manager heartbeat:> Leader License Manager 
periodically logs the update status received from all its followers

> Follower License Manager periodically logs the update about the contact established 
with the current leader License Manager

 l 5 Logs the usage information event, shared by the leader, regarding the number of 
tokens issued. 7 Logs the license token distribution information synchronization event.

 l 9 Logs when the License Manager is down.

 l 11 Logs addition of a license into the file or memory. Also logs deletion of a license from 
the memory.



Sentinel RMS License 9.7 Tools

lsrvdown: Shut Down the License Manager ǀ 130 of 150

lsrvdown: Shut Down the License Manager
 l This is related to the "Full Network Client Installations" on page 44 using the Sentinel 

RMS License Manager (Windows) or Server (Linux), version 9.7. 

 l The tool is applicable to Windows and Linux (32-bit and 64-bit) operating systems. See 
"Windows: Installing the Sentinel RMS License Manager" on page 48 or "Linux: Installing 
the Sentinel RMS License Server" on page 54.

lsrvdown utility is used to shut down the named License Manager. 

Platforms

Windows, Linux 32-bit, Linux 64-bit

 l On Windows and Linux 32-bit use lsrvdown host-name

 l On Linux 64-bit use lsrvdown64 host-name

lsrvdown can be run from the operating system command prompt by an administrative user on 
a client or License Manager computer. 

 l On UNIX, only the user logged in as “root” can use lsrvdown. 

 l On Windows, any user with administrative privileges may use lsrvdown unless the 
License Manager was started by a user logged in as Administrator, in which case only 
Administrator can shut the License Manager down. The computer on which you are 
running lsrvdown must be in the same network domain as the License Manager 
computer. 

The same user must install the Sentinel RMS License Manager and also run 
this utility.
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lswhere: Display a List of License Managers
 l This is related to the "Full Network Client Installations" on page 44 using the Sentinel 

RMS License Manager (Windows) or Server (Linux), version 9.7. 

 l The tool is applicable to Windows and Linux (32-bit and 64-bit) operating systems. See 
"Windows: Installing the Sentinel RMS License Manager" on page 48 or "Linux: Installing 
the Sentinel RMS License Server" on page 54.

Platforms

Windows, Linux 32-bit, Linux 64-bit

lswhere command displays the network names of the computers running the License Manager. 
By default, lswhere displays for each License Manager the address of the computer on which 
that License Manager is running as well as its host name.

lswhere can be run on Windows and UNIX. lswhere should be run from the operating system 
command prompt by an administrator or application user on a standalone, client, or License 
Manager computer.

lswhere should be run in the following format:

 l Windows and Linux 32-bit: lswhere [option] 

 l Linux 64-bit: lswhere64 [option]

Options

 l d Displays details on the License Managers found on the network.

 l r Displays only the IP addresses of the License Managers found on the network (resolves 
the host names). lswhere can also be run without specifying any command line options.
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WlmAdmin Administrative Tool
 l This is related to the "Full Network Client Installations" on page 44 using the Sentinel 

RMS License Manager for Windows, version 9.7. 

 l The tool is applicable to Windows  operating systems. See "Windows: Installing the 
Sentinel RMS License Manager" on page 48.

WlmAdmin performs a variety of administrative functions for the license management 
activities. It displays elaborate information that includes the License Manager information, 
feature information, and license and client information.

Platform

Windows

WlmAdmin can administer a remote Linux license server. 

WlmAdmin Functions

 l Provides information on the License Managers.

 l Details on licenses and clients using them in the network. For example, the 
administrator can see which users have acquired that license and who are in a queue 
waiting for the license.

If you are using redundant License Managers, you can use WlmAdmin as an informational tool 
to: 

 l Add or delete a redundant License Manager from the redundant License Manager file.

 l Display a list of all License Managers in the redundant License Manager pool and display 
the name of the License Manager leader.

 l Display the distribution criteria for specific licenses (only high assurance model is 
allowed, where the reigning leader server keeps all the license tokens).
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View License Manager Information

 l Click the name of a License Manager in the left-hand pane of the main window. In the 
right-hand pane of the display, you see the IP address of the computer containing the 
License Manager and its host name.

Add or Remove a License Manager from the Defined Server List

 l To add a License Manager:  Right-click the name of a License Manager in the list of 
Subnet Servers. From the menu select Add to Defined List.

 l To remove a License Manager: Right-click the name of a License Manager in the list of 
Defined Servers. From the menu select Remove from Defined List.

Add a License Code to the License Manager from a File

 1. Right-click the name of a License Manager in the left-hand pane of the main window.

 2. From the menu select Add Feature > From a File > To Server and its File.

 3. To add the license from a file, select From a File. This permanently adds the license code 
to the License Manager license file as well as to the License Manager memory.

 4. In the new windows, browse to the source file that contains the license code and click  
Open.

 5. Select the license code file.

Delete Old License Features from the License Manager

 1. Right-click the file WlmAdmin.exe and select Run as Administrator.

If the license server is not found under subnet servers, go to Edit > Defined Server List.

 2. Enter the host name or IP address of the license server.

 3. Click Add and OK.

 4. Click View > Refresh All to update the list.

 5. Right-click the name of a License Manager in the left-hand pane of the main window.

 6. From the menu select Remove all Features
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Shut Down a License Manager

 l Right-click the name of a License Manager in the left-hand pane of the main window. 
From the menu select Shutdown Server.

Setting WlmAdmin Preferences

WlmAdmin allows you to choose what to display when it starts.

From the Edit menu, select the Preferences command to view WlmAdmin Preferences: 

 l Timeout Interval: The number of seconds after which WlmAdmin will stop trying to 
contact a License Manager. If you have a large network or a slow one, you might want 
to increase this number if you find WlmAdmin has difficulty retrieving information from 
License Managers.

 l Broadcast Interval: Specify the number of seconds between broadcasts to the network 
to discover License Managers.

 l Server Port: To set any custom port (other than the default port 5093) on which the 
RMS License Manager is running.

Set this port number before you add that License Manager in the list of 
defined servers.

 l Discover subnet servers on startup: To automatically discover and display the License 
Managers on your subnet.
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 l Discover defined servers on startup: To always show the License Managers you have 
defined.

 l Show client library error handler messages: To pass license management error 
messages from Sentinel RMS to WlmAdmin.

 l Save these preferences to a file: To save your choices.
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Sldemo: Show Basic API Functions
 l This is related to the "Full Network Client Installations" on page 44 using the Sentinel 

RMS License Manager for Windows, version 9.7. 

 l The tool is applicable to Windows  operating systems. See "Windows: Installing the 
Sentinel RMS License Manager" on page 48.

slmdemo is a Windows-based graphical sample program to show basic API functions. Evaluate it 
using the steps described here to understand the basic API calls and test the connectivity 
between client and license server

slmdemo can be used to test the connectivity to a remote Linux license server

Platform

Windows

Right-click on the executable and select Run as administrator. slmdemo calls the VLSinitialize 
API when the application is invoked successfully.

https://docs.sentinel.thalesgroup.com/softwareandservices/RMS/RMSDocumentation/Vendor/Content/DevGuide/Chapter 5_LicensingAPIs/Getting Started With API.htm#Initiali
https://docs.sentinel.thalesgroup.com/softwareandservices/RMS/RMSDocumentation/Vendor/Content/DevGuide/Chapter 5_LicensingAPIs/Getting Started With API.htm#Initiali
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Set the contact server (License Manager) under the Connect To > Server menu option. Enter a 
hostname , which is the hostname or IP address of the License Server.
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Click  OK and enter in the field one of the license features available in the network license file. 
Where Feature is the name of the feature ex. TC_FULL and Version is the license version in the 
NWL (Network) license. Click  Get License. The message The call returned a success 
status of 0x0 means that the connection client <> license server works.
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To save the log, click File > Save log.
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Wechoid: Get a Computer Locking Code
 l This is related to the "Full Network Client Installations" on page 44 using the Sentinel 

RMS License Manager for Windows, version 9.7. 

 l The tool is applicable to Windows  operating systems. See "Windows: Installing the 
Sentinel RMS License Manager" on page 48.

Before your software vendor creates a license code with any computer restrictions, you must 
get the locking code for your computer with the Wechoid program. Your software vendor will 
tell you which computers you must run Wechoid on. The Wechoid utility outputs either one or 
two hexadecimal locking codes depending upon how your software vendor has configured it. 
You will send all locking information to your software vendor. Your software vendor will use 
this information, which is specific to your computers, to generate new license codes.

Platform

Windows

When launched, the utility shows the available lock criteria (a checkmark is added next to each) 
and the values. Click to clear (uncheck) all check boxes except for Ethernet Address.
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Updating or Uninstalling the Software
Also see "Uninstalling TC-Toolbox for MATLAB®" on page 112

In this section:

Updating the Software for Interim Releases 143

Uninstalling Thermo-Calc 149
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Updating the Software for Interim Releases
The full version of Thermo-Calc software is released twice a year. The software releases are 
named after the year of the release followed by an “a” for the first release of the year or a “b” 
for the second release of the year. For example, this release is 2023a.

Occasionally after a full release, an interim release version, an update, is required to fix a 
serious bug or to address an external issue that occurred after the full release. Software 
licenses come with a free 12 month Maintenance & Support Subscription, starting from the 
time of purchase, and this includes these software updates. 

Go to our website to confirm the current distributed software version and 
determine if there are updates, or to learn more about Maintenance and Support 
options. 

Installing an Updated Version of the Software

Step 1. Check for a Software Update

You can set your software to automatically check for updates upon start up.

 l From within the software select Tools → Options and set Check update interval to On 
start up.

 l If you do not have Automatic Updates on you can go to Help → Check for Updates.

https://thermocalc.com/current-software-versions/
https://thermocalc.com/maintenance-and-support/
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Step 2. Follow the Installation Instructions for the Applicable OS

After the software has checked for updates and determined there is one, the applicable 
installation file for your operating system is downloaded. Then follow the instructions provided 
in the Installation Guide for the specific operating system and license type. 

For an update to the software, no additional license files are required.  

Step 3. Option to Save Backup User Created Files

There are significant operating system differences regarding what backup files are 
saved if you are installing an update on Windows versus macOS or Linux. 

During the installation process, several default folders are added to your system that include 
documentation, materials, and example files. This is the same for all operating systems. During 
an update, Thermo-Calc runs a check of these default folders to determine if there are changed 
or new user files that are saved in these folders. For example, you might have saved a 
completely new project *.tcu file into the Examples folder, or after running one of the included 
examples such as T_06_Serial_Equilibrium_Calculators.tcu, the default file is changed and now 
includes results. 

On Windows operating systems,  Thermo-Calc gives you the opportunity after the installation to 
specifically save a backup of these user created or modified files to your Documents folder 
when you open Thermo-Calc for the first time after the update. 

However, for macOS and Linux operating systems, the behavior is different due to limitations 
enabling the identification of changes to some files. 

Operating 
System

When does backup 
occur?

What files are copied?

Windows

After installation, 
when you open the 
software for the first 
time

Documents, Materials, and/or Examples files are copied when you choose 
Yes at the prompt (see the Windows section for details).
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Operating 
System

When does backup 
occur?

What files are copied?

macOS

During installation

There is an option during the installation process to save a backup copy of 
the Examples folder even if no changes are made to files (see the macOS or 
Linux sections for details). 

Materials and Documents folders are not automatically 
copied even if there are file changes or additions. 
However, you can always manually back up these folders 
(see the macOS or Linux sections for details). Linux

Windows

First complete the installation update. Then when you open Thermo-Calc for the first time, and 
if Thermo-Calc identifies that there are changed files, you are prompted with a Software 
Update - Action Required window that identifies the folders where the applicable files are 
changed or added. 

These file types are not kept, i.e. these are excluded: dll, exe, lib, mltbx, pdf, whl, 
html, and htm.

Click Yes to save a backup of these  changed files or No to continue opening Thermo-Calc as 
normal where the default set of folders are copied from the source Public Documents location 
into a user Documents folder. 

If you choose to save a backup of the files, the new backup folder is added to this same 
location, for example:

C:\Users\<user>\Documents\Thermo-Calc\2023a_backup

"Installation Default Directory: Windows" on page 22 

macOS

During the installation process you are prompted with a Software Update - Action Required 
window. 
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This window always displays whether there are changes or additions to the folders 
or not. 

The Materials and Documentation folders do not automatically have a backup 
saved. If you think there are user files you want to keep it is recommended that 
you click Cancel at this prompt to exit the installer, then manually copy the folders 
to another location. Then start the installation update process again. 

To create a backup copy of the Examples folder, including changed files (i.e. all files are copied, 
not just the changed or new ones). Options at this prompt are to click:

 l Yes to create the backup.

 l No to replace all files. 

 l Cancel to exit the installation process, i.e. to manually save a backup of any other folder.

The default backup folder containing a full copy of all the contents of the Examples folder is 
saved to this location, for example:

/Users/Shared/Thermo-Calc/2023a/Examples_backup

"Installation Default Directory: macOS" on page 23
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Linux

During the installation process you are prompted with a Software Update - Action Required 
window. 

This window always displays whether there are changes or additions to the folders 
or not. 

The Materials and Documentation folders do not automatically have a backup 
saved. If you think there are user files you want to keep it is recommended that 
you click Cancel at this prompt to exit the installer, then manually copy the folders 
to another location. Then start the installation update process again. 

To create a backup copy of the Examples folder, including changed files (i.e. all files are copied, 
not just the changed or new ones). Options at this prompt are to click:

 l Yes to create the backup.

 l No to replace all files. 

 l Cancel to exit the installation process, i.e. to manually save a backup of any other folder.

The default backup folder containing a full copy of all the contents of the Examples folder for 
Linux depends if you are a root super user requiring administrative privileges or a common 
user. 
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For example, for a common user:

/home/<user>/Thermo-Calc/2023a/Examples_backup

For example, for a root user:

/opt/Thermo-Calc/2023a/Examples_backup

"Installation Default Directory: Linux" on page 24
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Uninstalling Thermo-Calc
"Uninstalling TC-Toolbox for MATLAB®" on page 112

Windows 10

 1. From the Control Panel Desktop app, go to Programs → Programs and Features → 
Uninstall or change a program.

 2. In the list of programs, locate the version of Thermo-Calc you want to uninstall. Click to 
highlight that row.

 3. Click Uninstall/Change.

 4. In the Setup window, Uninstallation Mode dialog box, choose to uninstall the Entire 
application or Individual components. Follow the instructions to finish.

macOS 

Deleting the program from the Applications folder does not remove the program from your 
operating system. Run the Thermo-Calc-<version>-uninstaller program located in the 
Applications folder. 

 1. Go to the Applications folder and double click the file that starts with Thermo-Calc-
<version>-uninstaller. Enter the administrator’s user name and password.

 2. Click Yes to choose Entire application or select individual components. Otherwise click 
No to quit.

 3. The Uninstalling Thermo-Calc window shows the progress. Click OK when prompted.

Linux

 1. To start the uninstallation procedure, in the Thermo-Calc installation directory use the 
command
./Thermo-Calc-2023a-uninstaller.run

For Thin Client installations, use the command 

./Thermo-Calc-client-2023a-uninstaller.run
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 2. To remove the whole application, including all its components, select Entire application 
and click Forward, or to remove specific components, select Individual components and 
click Forward. 

If you intend to reinstall Thermo-Calc 2023a it is important to (1) Restart the 
computer before you reinstall the software and (2) remove the environmental 
variable TC23A_HOME. 
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